Results 1 to 19 of 19
  1. #1
    RC Competitor
    Join Date
    Feb 2012
    Posts
    84

    Thumbs down Burned Castle Motor 2200KV (Pictures Inside)

    Hi guys,

    Was running on 6S for about 10min non-stop yesterday when my motors burned... bummed, not sure if a motor repair kit like this one http://www.amainhobbies.com/product_...it-1515-2200kV would definitely fix it or if I need more, maybe send it into Castle before buying repair kit... but then I have to wait several weeks.





    Anyway, any thoughts will be much appreciated.

    Tks!

  2. #2
    RC Champion
    Join Date
    Apr 2007
    Location
    Valrico, FL
    Posts
    1,679
    wow...rotor must have locked up or something?

    A new rotor and bearings might get you up again but if it were me I'd be worried more was wrong ( I don't like seeing that broken wire end sticking out there in the one picture?). I would just send it to castle to get it repaired or replaced...that should be free if your still under warranty but even if your not it's quite a bit cheaper than a new motor...bad part is being without a motor for a few weeks.
    -ERBE
    -Slash 4x4

  3. #3
    RC Competitor
    Join Date
    Feb 2012
    Posts
    84
    I forked out $50 for repair kit.. if it doesn't work, I'll ship it to Castle folks... just hate waiting 3-5 weeks... I opened both ends and red wire burned at the back, we'll see what happens I'll tape it for now.

  4. #4
    RC Racer
    Join Date
    Sep 2009
    Posts
    133
    i have a basically brand new motor on ebay currently going for 100

  5. #5
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Planet Vegeta
    Posts
    651
    it looks super dirty in there, or is that the burns
    All I need now is to set a new lap record.

  6. #6
    RC Qualifier
    Join Date
    Oct 2005
    Location
    GR, MI
    Posts
    670
    your should pull the back cover off and check that red wire. It looked like the insulation was broke or melted.
    i wonder if you can check the resistance in the windings to make sure there is not a short. If not, then you may be ok..

  7. #7
    RC Champion
    Join Date
    Jul 2007
    Location
    Rc Room
    Posts
    1,484
    I wonder if muck read post #3?

  8. #8
    RC Qualifier
    Join Date
    Oct 2005
    Location
    GR, MI
    Posts
    670
    Quote Originally Posted by BL-Bob View Post
    I wonder if muck read post #3?
    ooops, i did but fast LOL... Tape i do not think will hold with the heat inside. Liquid tape may. Instead of sending it to castle to fix the wire, look to see if you have an electric motor shop around your area. They maybe able to help.

  9. #9
    RC Competitor
    Join Date
    Feb 2012
    Posts
    84
    Thanks for all the help guys, I'll see if I can get someone to help me w burned red wire.. think you're right, electrical tape might not withstand the heat in ther..

  10. #10
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Wales. Uk
    Posts
    741
    The red wire doesn't look burned to me, looks like some fluff on the wire. Are we talking about picture 3?
    Signature removed due to excess awesomeness.

  11. #11
    RC Competitor
    Join Date
    Feb 2012
    Posts
    84
    I removed the bottom bell, it's burned on the backside you can't see it in these pictures, you're right it's just fluff in picture #3.

  12. #12
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Wales. Uk
    Posts
    741
    Can you slip some heat shrink over it?
    Signature removed due to excess awesomeness.

  13. #13
    RC Champion
    Join Date
    Mar 2005
    Location
    Des Moines
    Posts
    2,559
    I personally wouldn't trust that loose wire. It's one of the coil wires and there are no "spares" inside, so any broken wires may cause undesirable operation if not worse. I would keep the rebuild kit for future use and just send the whole motor in.
    http://scriptasylum.com/rc_speed/

  14. #14
    RC Competitor
    Join Date
    Jan 2014
    Posts
    88
    At the Nolimitrc world finals last weekend, the rotor in my emaxx shattered and everything got hot. Batteries were just plugged up for about 20 seconds total. The rear diff gear broke off. I think the gear broke and clogged up the drivetrain and the 6s lipo voltage going to the motor(which couldn't turn because of the gear) made the motor want to turn but if couldn't so if just ripped the magnet up. I'm using my phone for this post, if you want a picture just reply and quote this post so I can post a picture in Tapatalk please!!!

  15. #15
    RC Competitor
    Join Date
    Jan 2014
    Posts
    88

    And

  16. #16
    RC Qualifier
    Join Date
    Aug 2013
    Posts
    894
    Ruined in 10min? That's weird.

  17. #17
    RC Qualifier
    Join Date
    May 2012
    Location
    Portugal
    Posts
    408
    Quote Originally Posted by NFS View Post
    Ruined in 10min? That's weird.
    It depends.... any living creature could die in less then one second... so that piece survived 9 minutes in the hands of a human creature on 6s... it's actually awesome the quality of those motors....

    I am still wondering HOW you guy's play more then 10minutes without heat shutoff and no meltdown of ESC/motor's runing those Big Joes lalaland on 6s... and cry when something is broken having a Traxxas RC And spend fortunes on upgrades that do nothing more then just a run pack without spending another fortune for another Pack....you know... for those power hungry systems there are actually other brands of rc that of the shelf do not need upgrades and stay that way with years of abuse... but go Traxxas, go.... I love my 1/10 and 1/16 erv's


    American's....lol


    As for that motor "check the resistance in the windings to make sure there is not a short"... if all good buy a rebuild kit... and get ceramic bearings this time (Boca Orange?)
    It will make your motor fly more with less heat....noticable!
    Make sure all 3 wires are still firm and rock solid coming from the windings... if have doubts don't run it... ESC will be killed in the process even with the rebulid kit... cause it's only stock bearings and stock rotor, windings will be the same that have burned??? hum....
    (the coils varnish could have disaperad cause of heat on some places and that could eventually lead to a short somewhere when you jump or just drive)

    All that IMHO!
    Last edited by targetingxmod; 05-27-2014 at 03:19 AM.

  18. #18
    RC Competitor
    Join Date
    Jan 2014
    Posts
    88
    Mine was ruined in like 10 seconds.

  19. #19
    RC Competitor
    Join Date
    Jan 2014
    Posts
    88
    You can mail it back to castle (with proper paperwork and registration) and pay half the regular price and get a new motor with a new warranty. if your castle product is out of warranty

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •