Results 1 to 3 of 3

Hybrid View

  1. #1
    RC Competitor
    Join Date
    Dec 2010
    Location
    Longview, TX
    Posts
    74

    Unhappy XL-5 Pede Converted to 2.4G Radio, Now stuck in LVC mode...HELP!

    Ok folks. Buddy has a brushed Pede running a XL-5 ESC. He just put a 2.4G radio on it and couldn't get the throttle to work after putting the new radio on. Gave it to me to work on as I have 2 nitro and 2 electrics that I all converted to Traxxas 2.4G a couple months back.

    So, I got the throttle working. Somewhere along the way I turned on the LVC, not sure how I managed that, sure didn't hold the button for 10seconds! Now I cannot get LVC off. I have tried to hold the ESC button down with the radio on and with the radio off. Every time I do, the green light goes off, the receiver light shows power is still on, and nothing else happens. 10s, 15s, 20s, doesn't matter how long I hold it. When I let off the button, the power shuts off, no red light. When I power back on, still stuck in LVC mode.

    Any thoughts on how to reset the thing back to stock, non-LVC, red light on mode!?!?!?
    Last edited by goodie1977; 05-03-2012 at 09:16 PM.

  2. #2
    RC Competitor
    Join Date
    Dec 2010
    Location
    Longview, TX
    Posts
    74
    Never mind. I just assumed his unit was LiPo ready like mine were. But, nope, it is not! So the green light is as expected. It does not have the sticker on the front, so it isn't an LVC model. Stupid me!

  3. #3
    RC Turnbuckle Jr.
    Join Date
    May 2011
    Location
    Fraser Valley, BC Canada
    Posts
    3,137
    That's what I was going to ask.
    I don't have shelf queens, I have bash kings!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •