Results 1 to 9 of 9

Thread: Please Help!!

  1. #1
    RC poster
    Join Date
    Aug 2014
    Posts
    8

    Please Help!!

    My EVX-2 is on and the light is green for lipo mode. I have a 2s 5200 mah battery hooked to it and it steers my wheels but does not move motor at all.....I tried the troubleshooting method of puting a battery to the 775 and it jumped but still doesnt run hooked up to the EVX-2.....someone please help!!

  2. #2
    RC Qualifier
    Join Date
    Jul 2013
    Location
    Connecticut
    Posts
    640

    Please Help!!

    This might help as the EVX-2 works on two batteries. Lipo 4s which means you need two 2s lipos hooked up. or two NIMH packs. One 2s lipo won't turn the motor.
    Last edited by Spencer911; 08-24-2014 at 10:22 AM.

  3. #3
    RC Champion
    Join Date
    Apr 2011
    Posts
    2,088
    you just need to recalibrate the esc..........then it should work.

    http://traxxas.com/video/Accessories...ed-Control-ESC

  4. #4
    RC Qualifier
    Join Date
    Jul 2013
    Location
    Connecticut
    Posts
    640
    you need two packs thats the issue. the EVX-2 wires the batteries in series. so if you don't have both batteries installed it won't work. Also try what jaman said to re-calibrate the speed controller.
    Last edited by Spencer911; 08-24-2014 at 10:26 AM.

  5. #5
    RC Champion
    Join Date
    Apr 2011
    Posts
    2,088
    thought he made a typo in the original post and meant to say had 2 batteries connected, cause if only one is connected I don't think the steering will work let alone turn on.....
    Quote Originally Posted by Spencer911 View Post
    you need two packs thats the issue. the EVX-2 wires the batteries in series. so if you don't have both batteries installed it won't work. Also try what jaman said to re-calibrate the speed controller.

  6. #6
    RC poster
    Join Date
    Aug 2014
    Posts
    8
    When I have one battery connected it turns my lights on and steers the wheels but motor doesnt do anything....

  7. #7
    RC poster
    Join Date
    Aug 2014
    Posts
    8
    When I connected my other 2s, it worked....I thought I could have one battery plugged in....Thanks Guys!!!

  8. #8
    RC Racer
    Join Date
    Mar 2012
    Location
    Sherbrooke Qc, Canada
    Posts
    161
    Yes, if you have one battery on the BEC side your steering and lights will work, but it takes two batteries for the motor to work.
    Tekin powered Summit

  9. #9
    RC Champion
    Join Date
    Apr 2011
    Posts
    2,088
    intresting......this gives me an idea for a build....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •