Results 1 to 13 of 13
  1. #1
    RC poster
    Join Date
    Apr 2012
    Location
    Oakville,On Canada
    Posts
    10

    EVX-2 Not working HELP

    I just got this new Summit today worked fine for the 1st time (5 MIN) and then i went to use it the 2nd time and the ESC is blinking red and green and won't go all servo's working but no gas!!!!

    HELP???

  2. #2
    RC Competitor
    Join Date
    Mar 2012
    Posts
    67
    I forget what it specifically means, but the red and green blinking is notated in the manual. Give that a peek and it might help you out.

  3. #3
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,472
    Did you charge the batteries between uses?
    Alt-248 on the number pad =

  4. #4
    RC Competitor
    Join Date
    Mar 2012
    Location
    Pittsburgh
    Posts
    91
    Over voltage protection. Discharge batteries and make sure esc is set to nimh.
    Summit w/ TQi
    Rustler VXL

  5. #5
    RC Qualifier
    Join Date
    Jan 2012
    Posts
    260
    perhaps we need to have an faq on the evx2 LVD version pinned up.
    looks like almost everyday there's a question on it.

  6. #6
    RC poster
    Join Date
    Apr 2012
    Location
    On the lake. Livingston Texas.
    Posts
    14
    EVX2 might be set for LiPos,( check the one page supplement that came with your paper wok) ive read several others having similar issues.
    Protect the 2nd amendment.......with vigor.

  7. #7
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,280
    I have a picture posted of the sheet in my build thread...
    (sorry I am on my phone and cannot post links easily)
    Whatever it is I just said... I could be wrong.

  8. #8
    RC Competitor
    Join Date
    Mar 2012
    Location
    Pittsburgh
    Posts
    91
    I think that may be part of the problem, I don't recall seeing anything about a flashing red/green condition on that addendum. I emailed Traxxas about it when I went through my ordeal and acknowledged my suggestion so hopefully they'll get it squeezed in somewhere.
    Summit w/ TQi
    Rustler VXL

  9. #9
    RC poster
    Join Date
    Dec 2011
    Posts
    9

    Smile answer

    Quote Originally Posted by jafo7489 View Post
    I just got this new Summit today worked fine for the 1st time (5 MIN) and then i went to use it the 2nd time and the ESC is blinking red and green and won't go all servo's working but no gas!!!!

    HELP???
    my servo was one time like that. first you need to connect two battery you use for the car. second turn on and hold when servo blinking red (only red) then took you finger out, and put you finger in back and press and hold when the servo blinking three time green light on servo, that's it, and turn it off. then turn on your radio first, then turn on you servo on and run. it is not from battery or from servo, something did touch and hold it. thanks you

  10. #10
    RC poster
    Join Date
    Dec 2011
    Posts
    9

  11. #11
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,472
    The flashing red-green indicates an over-voltage condition in LVD-enabled (green LED) mode.

    The following steps change the LVD mode to DISABLED. This is slightly simpler, but no video.
    1. Connect ONE fully charged, stock 8.4V pack to the EVX-2's BEC-side power connector ONLY.
    2. Turn on the EXV-2 by pressing the on/off button. (LED lights up.)
    3. Release and immediately press (again) and hold the on/off button until LVD mode changes.
    4. Release, plug in second battery, turn ESC on and have fun with your NiMH-powered truck!
    Alt-248 on the number pad =

  12. #12
    RC poster
    Join Date
    Dec 2011
    Posts
    9

    answer

    yearh that easy to fix

  13. #13
    RC poster
    Join Date
    Dec 2011
    Posts
    9
    4. Release, plug in second battery, turn ESC on and have fun with your NiMH-powered truck! THAT is wrong sir
    4. Release, plug in second battery, then turn esc of then turn on when you see green light took you finger out, and ready to run,the erro is not from the battery sir

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •