Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Apr 2012
    Posts
    3

    Velineon VXL-3s ESC issue

    Hey,

    I got my a brand new truck yesterday, Slash 4wd ultimate.
    Today after the first run I managed to screw it

    At first everything was great drove it at beach, then the battery seems a bit slow so I went home after about 20 minutes (stock battery).

    After a quick clean up and a battery recharge turned it the ESC on but this time only the servo would work.
    Motor is not responding, servo works perfectly via remote. ESC got no lights at all. blank spot where it supposed to be green/red, also I'm unable to shutdown the ESC at all, it only works to turn in ON, right after it's on it feels stuck.

    I'm new to RC and reaching out for your ideas and thoughts.

    What shall I do?

    Thanks,
    Oleg.

  2. #2
    RC Enthusiast
    Join Date
    Dec 2011
    Location
    Melbourne, Australia
    Posts
    31
    take it back Traxxas will replace electronic parts for upto 30 days after purchase......

  3. #3
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Corpus Christi, TX
    Posts
    466
    It sounds like the ESC button is stuck. Do a quick search here for stuck esc and there will be some recommendations on how to fix it. Also, some things to help you keep it from getting stuck.

  4. #4
    RC poster
    Join Date
    Apr 2012
    Posts
    3
    Bought it via ebay, I'm not from the US..
    Gotta fix it myself, but first identify the issue.

  5. #5
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Corpus Christi, TX
    Posts
    466
    Yeah, and give Traxxas a call. They might ship a new one right out to you. Or might just make you mail yours back to them, wait a few days, then send you a new one.

  6. #6
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    El Sobrante, Ca
    Posts
    7,549
    The button on the VXL esc is notorious for becoming stuck. I recommend calling Traxxas and trying to get a warranty replacement.
    Slash Ultimate, ET-3S, 2400, MIP, King Headz, RPM

  7. #7
    RC poster
    Join Date
    Apr 2012
    Posts
    3
    I'll call them.. I'm just wondering if I did something wrong or it's just faulty hardware.

  8. #8
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    El Sobrante, Ca
    Posts
    7,549
    It's not your fault. If you do a search, there are plenty of people that have experienced the same thing. I will give a pointer. If you send the esc in, send the motor with it. That way if the motor is bad you can get them replaced at the same time. It would be awful to get a new esc and find out the motor is bad and have to wait for a new motor. Good luck and welcome to the Slash 4x4 forum and the addiction
    Slash Ultimate, ET-3S, 2400, MIP, King Headz, RPM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •