Results 1 to 10 of 10

Thread: XO-1 Beeps

  1. #1
    RC Enthusiast
    Join Date
    Apr 2012
    Posts
    30

    XO-1 Beeps

    I just got my XO-1 today. An amazing machine. But I have a question. When I turn it on i get the 6 lipo beeps. But when it sits in neutral, I get a beep every few seconds and the ESC blinks red when it beeps. What does that mean? It does drive ( fast ) though. No problems there

    Thanks already for the help and sorry if its a noob question

  2. #2
    RC Racer
    Join Date
    Feb 2012
    Posts
    137
    your esc should flash yellow , if it is red that means you need to trim your throttle settings to neutral.

  3. #3
    RC Enthusiast
    Join Date
    Apr 2012
    Posts
    30
    Quote Originally Posted by 1azz View Post
    your esc should flash yellow , if it is red that means you need to trim your throttle settings to neutral.
    So thats all there's wrong you think? I am gonna try that right away

  4. #4
    RC Racer
    Join Date
    Feb 2012
    Posts
    137
    yes its just a throttle trim problem. 100 percent sure.

  5. #5
    RC Enthusiast
    Join Date
    Apr 2012
    Posts
    30
    Working now Thanks a lot If I run into more noob problems I will let you know

  6. #6
    RC Racer
    Join Date
    Feb 2012
    Posts
    137
    no worries.Thats what we are here for

  7. #7
    RC poster
    Join Date
    Feb 2012
    Posts
    1
    Guys if u could help me out with somthing that would be amazing ok so my traxxas xo1 decided to drive smoothly and awesomly fast but i didnt run out the battery low at all this is a new ESC from castle and im wondering what the issue is it turns on steering is fine but when i throttle it nothing happens it just keeps blinking a light and beeping and doesnt stop it does this even tho i retry and connect it to sync with controller and both lights on controller and reciever are GREEN
    ive gotten this car up to 75MPH even with out the other spur in and unlocked awesome car but the issue still remains wont drive cause it beeps if somone can help
    email : mattchu247@gmail.com

  8. #8
    RC Racer
    Join Date
    Apr 2012
    Location
    Central, WI.
    Posts
    235
    Do you have it plugged into channel 2 ?? I think there are 2 channel 1's

  9. #9
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Brooklyn Park, MN
    Posts
    991
    There are two channel ones, I was so annoyed when my truck wouldn't work, what a DERP moment.
    MM|2200kv 2WD LCG Slash - MM2|2650kv LCG Slash 4x4

  10. #10
    RC Qualifier
    Join Date
    Feb 2012
    Posts
    692
    which gear did you do 75mph on ? 19tooth?
    did you program esc after pluggin into receiver when u got new one
    XO-1,SLASH 4X4 ,SLASH 2WD , 2/RUSTLER

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •