Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    Apr 2012
    Location
    Sierra Vista, AZ
    Posts
    5

    ESC problem! Need help!!!

    I have a stock F150 Raptor, (Slash 2wd) 12T motor w/XL-5 ESC, and I was running it the other day and after switching to a fresh battery i lost all motor control i.e. no forward or reverse. Did some research online and found ESC troubleshooting. Verified transmitter was still set to factory default, did procedures for ESC programming and when I reconnect the motor lead motor would run in forward, brake, but when I go to reverse I loose control again!!!! Anybody had this problem?
    Last edited by kealii1967; 04-13-2012 at 10:53 AM.

  2. #2
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    It sounds more like a reciever or transmitter problem than an esc problem. See if your rx got wet.
    By the way welcome to forum come here whenever you have a ?.
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  3. #3
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Vancouver, B.C. Canada
    Posts
    255
    ya upbasher is right the xl-5 is a pretty harty esc so check ur reciver
    Slash 2wd Vxl, ERBE; Crash N Learn

  4. #4
    RC poster
    Join Date
    Apr 2012
    Location
    Sierra Vista, AZ
    Posts
    5
    Haven't run in wet conditions ever, kinda dry out here in AZ. Anyway, i still have steering control, just no motor control! I am a newbie to the R/C world so...

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Oct 2009
    Location
    Springfield, MO
    Posts
    3,681
    Sounds like dirty motor brushes to me.

    You can try putting the motor under water, and then running low volts, like a single C or D battery to it, it'll spin while submerged and blow a ton of crap out, turning the water murky.

  6. #6
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Vancouver, B.C. Canada
    Posts
    255
    AZ hey, did you just buy the truck at barrett jackson?
    Quote Originally Posted by kealii1967 View Post
    Haven't run in wet conditions ever, kinda dry out here in AZ. Anyway, i still have steering control, just no motor control! I am a newbie to the R/C world so...
    Slash 2wd Vxl, ERBE; Crash N Learn

  7. #7
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Pomona CA.
    Posts
    327
    I also bought the Traxxas Slash 2wd #5803 and after two battery uses the car stopped working, it would steer but no throttle . the car wouldnt move , I also thought it was my esc (xl-5) so i took it to the pros at Pegasus Hobby shop, where i bought it . They ended up just giving me another transmitter, somehow my transmitter stopped working , first time for everything they said , lucky for me they gave me the one with the ipod dock station , free of charge. I didnt drop it "i think", or anything serious , so i wonder why it stopped working. The stock transmitter that it came with is the Tqi 2.4 ghz . sounds like its the same problem (exactly the same problem ) i had. Hopefully you still have your receipt and your store is able to help you out. oh yeah and they kept my old transmitter.

  8. #8
    RC poster
    Join Date
    Apr 2012
    Location
    Sierra Vista, AZ
    Posts
    5
    Thanks for all the input! I took it to the shop and we tested the motor, it failed! So got a new 12T motor and all is well again! Gonna be getting a brushless motor soon, not to thrilled with the very short life span of the 12T!

  9. #9
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Vancouver, B.C. Canada
    Posts
    255
    keallii did you buy the truck at barret jackson scotts dale by any chance?
    Quote Originally Posted by kealii1967 View Post
    Thanks for all the input! I took it to the shop and we tested the motor, it failed! So got a new 12T motor and all is well again! Gonna be getting a brushless motor soon, not to thrilled with the very short life span of the 12T!
    Slash 2wd Vxl, ERBE; Crash N Learn

  10. #10
    RC poster
    Join Date
    Apr 2012
    Location
    Sierra Vista, AZ
    Posts
    5
    No I didn't. Got it online from Tower Hobbies.
    Quote Originally Posted by wmckay96 View Post
    keallii did you buy the truck at barret jackson scotts dale by any chance?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •