Results 1 to 4 of 4

Thread: ESC problems?

  1. #1
    RC poster
    Join Date
    Feb 2012
    Location
    Paradise, CA
    Posts
    11

    ESC problems?

    My summit will just stop running all of the sudden, the esc turns off by its self. I turn it back on and it runs for a few seconds then shuts off again. Its not over heated, and the batteries in the truck and controller and new and charged. Does this sound like I need a new esc? Or could it be a reciever problem?
    Thanks,
    Adam

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,280
    Try unplugging your servo first... sounds weird, I know; but give it a try.
    Whatever it is I just said... I could be wrong.

  3. #3
    RC poster
    Join Date
    Feb 2012
    Location
    Paradise, CA
    Posts
    11
    Hey Jimmie, yah I tired that too, and putting in a different servo alltogether. Still had the same problem with the esc shutting off. Going to send the esc back to traxxas, hope that is the problem. Thanks!

  4. #4
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Woodward, OK
    Posts
    430
    are you running two bat's in series? I had the same problem with nihms in series. I switched to parallel, and the problem went away. Now I run two 2s lipo in parallel. Also, are running a fan, I tried to run a heat sink with a fan, and this would happen to me.
    Last edited by westoakmech; 04-10-2012 at 08:17 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •