Results 1 to 12 of 12
  1. #1
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95

    Question throttle trim not workin??

    hey guys i changed my velieon motor to a 2400mmp sct. but now the throttle trim on the controler dont work yet the steerin trim is still workin ok ? any ideas? i done all the programing steps that came with the new motor , dont get me wrong the car is runnin ok wheeling and all that jazz, but there is play in the trigger before motor kicks in so need the throttle trim to be workin?? help please

  2. #2
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    Centre the throttle trim
    Set your throttle / brake EPA's (travel) at 100%
    Calibrate ESC to your transmitter

    Apply trim if needed

    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  3. #3
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95
    sorry can you go into detail about the set your throttle/brake epas travel at 100 part and the calibrate esc to your transmitter bit? cos im a lil slow, sorry man .. thanks for your help and time

  4. #4
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95
    I've calibrated the esc to the transmitter , and all the lights are correct and car runs .. Just no throttle trim workin??

  5. #5
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    Read the manual for your transmitter

    You should know what EPA (End point adjustment) also called travel does


    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  6. #6
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95
    thanls.. not! iv programed the controler and i still never see epa , and nothin i do seems to fix this issue

  7. #7
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    What transmitter do you have ?

    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  8. #8
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95
    its the stock 1 traxxas link 2.4gh, .. sorry if i never explained properly.. i brought a slash 4x4 ultimate that came with a stock velieon motor that i burnt out and when i had the veleion motor runnin the throttle trim worked fine,, so i purchessed a mamba max pro short course truck edition motor and esc combo from castle installed it in the car , everything seems ok but i know it aint right cos i cant get this poxy throttle trim to work again.. ive gone thro loads of crap.. tried to program to controler program the esc calibrate etc etc.. gettin frustrated.. thanks for ur help tho my friend

  9. #9
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95
    heres a pic


    Last edited by mrgreenfingers; 04-09-2012 at 05:59 AM.

  10. #10
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95

  11. #11
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    Page 4 of the user manual shows how to set the EPA's

    http://traxxas.com/sites/default/fil...24GHz-INST.pdf


    Try reversing the throttle channel on your transmitter and running the calibration again, if the motor spins the wrong direction swap any two motor wires


    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  12. #12
    RC Competitor
    Join Date
    Jan 2012
    Posts
    95
    hey thanks guys.. i worked it out lookin at page 4.. easy when you know how.. nice 1 crusey

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •