Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Apr 2012
    Posts
    2

    Top speed issues

    I bought a 6 year old, very slightly used e revo from a friend. MMM system. Both the ESC and motor are brand new via replacement from Castle. With brand new 3s lipos and 18/54 gearing I'm struggling to hit 45 mph. Did the torque test with castle and the kv on the motor is fine. No transmission issues as there's plenty of torque and without the pinion engaged it rolls smooth.

    Any advice?

  2. #2
    RC Qualifier
    Join Date
    Jan 2012
    Location
    Wichita, Kansas
    Posts
    251
    Is it possible that it is in training mode?

  3. #3
    RC Champion
    Join Date
    Jul 2007
    Location
    Rc Room
    Posts
    1,484
    Running forward in reverse? Calibrate esc to radio?

  4. #4
    RC Qualifier
    Join Date
    Dec 2011
    Posts
    356
    To hit 65 mph you need to gear it 21 / 54 ...

    What kind of tires are on it ? What kind of surface did you ran it on ? There are a lot of variants ...

  5. #5
    RC Racer
    Join Date
    Sep 2009
    Posts
    133
    better than that..... try 28/50.... smiles

  6. #6
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    6,654
    yeah, it sounds like the esc isn't calibrated correctly or the motor isn't wired correctly or both. make sure the motor wires go A to A and B to B and C to C. otherwise it will run sluggish.
    Associated rc8TE, rc8.2E, B4.2, Ofna LX2E, Slash

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •