Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Mar 2011
    Posts
    8

    Failsafe - programming setting up throttle neutral on receiver

    Greetings all. I have a problem with my traxxas 6518 receiver. When traxxas remote controller is turned off, the failsafe position on the receiver will not go neutral. Instead, Motor will activate in full throttle, untill I re-enable the transmitter on.

    I read some where, page 15 on the manual, that resetting it back to neutral throttle could be possible. I have followed the instruction, but the receiver does not go red as the instruction mentions after pressing and holding the link button. Instead it is always green. Do i need to hold for more than 30 seconds?

    The instruction stated to turn both receiver and transmitter on. Then press and hold link button untill it blinks red. On this step, my receiver does not perform. Is this instruction not ment for the 6518 receiver since its newer model?

    Thanks
    Last edited by Great2bfree; 03-31-2012 at 06:16 PM.

  2. #2
    RC poster
    Join Date
    Mar 2011
    Posts
    8
    Customer services failed. Figured out that its a logic/software bug on the receiver. Firmware upgrade using tqi transmitter and iphone resolved it.

  3. #3
    RC Competitor
    Join Date
    Dec 2010
    Location
    Longview, TX
    Posts
    97
    Quote Originally Posted by Great2bfree View Post
    Customer services failed. Figured out that its a logic/software bug on the receiver. Firmware upgrade using tqi transmitter and iphone resolved it.
    Wish it was that easy on the old High Output 2.4 Link units...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •