Results 1 to 4 of 4
  1. #1
    RC Qualifier
    Join Date
    May 2011
    Posts
    374

    Is it my reciever ??????

    I plugged my batteries in with my controller on and then tried turning the truck on the esc turned on and had a green light then when to nothing but i could still hear that it was on. I turned off the controller and the green light came back on, when I turned the controller back on the light switched off again leaving no control....I tried adjusting the throttle dial but nothing changed???????

  2. #2
    RC Racer
    Join Date
    May 2009
    Location
    MinneSNOWta!
    Posts
    217
    You should always make sure you are turning the controller on before the esc. Try setting the throttle trim to 0 and then reprogramming the esc.
    E-MAXX 3905 + Villain IV + Rustler VXL

  3. #3
    RC Champion
    Join Date
    Sep 2011
    Posts
    1,350
    Try fresh batteries in your Tx. Weak batteries in the Tx can make the truck do weird things.

    I've also heard that the 27mhz systems can be touchy and sensitive as the get older, something to do with the crystals I think.

    If putting fresh "AA" in your Tx doesn't solve the problem and you can rule out interference then I think the 2.4ghz upgrade may be in order. I had buddy do this with his MERV through our LHS. I think he said it was like a $60 upgrade.

    If you have another 27mhz receiver you could try putting that in your Maxx to rule out or pinpoint the receiver.

  4. #4
    RC Qualifier
    Join Date
    May 2011
    Posts
    374
    So i checked my controller batteries and they were fine my batteries for the truck were recently charged in the morning, so what i did was reset the esc and them tried different batteries for the truck...might have been a dead cell....and there was my problem so it works now thanks for all the support..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •