Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Feb 2013
    Location
    East Berlin,PA
    Posts
    3

    my slayer won't go

    after breaking in the new eng. my son played with it for ten min. then it reved up but didn't go. I replaced the slipper clutch and the clutch shoes didn't change anything. does anyone have any ideas for me to try. thank you

  2. #2
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,352
    Welcome to the fourms! Did you tighten down the slipper clutch all of the way down? If you give it gas, does it move a little bit, or not at all?
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  3. #3
    RC poster
    Join Date
    Feb 2013
    Location
    East Berlin,PA
    Posts
    3
    no i did not have it tight. i adjusted like the manual said. i'll try it tight if that doesn't work any other ideas. i did take the trans apart nothing is broke and everything spins smooth. thanks

  4. #4
    RC Qualifier
    Join Date
    Oct 2011
    Location
    naptown
    Posts
    588
    Set your slayer on the ground and hold your spur gear tight and try rolling it back and forth if you can theres a good chance you snapped a pin in the transmission. Pretty easy fix I'll have to check for the part number you'll need but only like 8-9 bucks if its that pin. Comes with a couple new gears for tranny also..

  5. #5
    RC poster
    Join Date
    Feb 2013
    Location
    East Berlin,PA
    Posts
    3
    thanks for your advice apparently i did not have the slipper clutch tight enough now it works. thank you both

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •