Results 1 to 15 of 15

Thread: Bad LUCK!

  1. #1
    RC Racer
    Join Date
    Feb 2012
    Posts
    212

    Bad LUCK!

    I purchased a Traxxas 11.1v 1400mah 3s battery . Put it onto my dynamite prophet sport lipo charger set to 3s @ 3 amp i left it over night the first charge used it worked ok not full power nor did it last ..... put back on charger left for another day plug into 1/16 e revo vxl and the truck wont stay on long enuf to mess with at all??? venom lipo did the same thing .........HELP im tired of wasting money on lipos that dont work .......?????
    Last edited by e-revoPCB; 03-19-2012 at 01:22 PM.

  2. #2
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    any advive?

  3. #3
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    you never want to leave lipos plugged in over night on anything like a charger or the esc, as it will catch fire or damage the lipo. if you put it back on the charger and did it again then thats going to be your trouble, and by the way i think you exceeded the maxx charge rate for the lipo your talking about, its only suppose to be a max of 2C charge rate and you went over that you were over by .2C which isnt much its only 200mah more but lipos when over charged at the max rate can get damaged easy like that. you should not be exceeding 2.8amps or 2.8C i frankly would only charge at no more than 1C-1.4amps to maximize battery life.
    DEU 8:18 ESV

  4. #4
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    So how long do you recomind charging first time then after

  5. #5
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    MY nooby fault for that i feel like an idiot and wasted 60 bucks on lipos.!!!!!!!!!! is it possible because the first time i charged the battery it ran ok ....... could i have overcharged it and now it wont hold a charge ..?????????????
    Last edited by e-revoPCB; 03-20-2012 at 12:08 AM.

  6. #6
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    its not that you ran it ok its that you over charged it and a cell went bad in lipo. does you charger have a display of the cell voltage? not too familar with the charger you mentioned. if not then get a display lipo cell checker and see what each cell is at. i'm almost sure one of the cells is bad or very inbalanced. your not running them down beyond 3.4v per cell right? your esc should be set in LVC mode green light on the esc and slow very hard when hitting that and you should stop running them then. are they puffed at all? do they heat up during charging and running them at all?
    DEU 8:18 ESV

  7. #7
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    no it diddnt heat up when i ran it....the venoms puffed but i LEFt them on the charger duh..... no my charger doesnt its a basic charger .......should i buy another lipo and try again????

  8. #8
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    that charger should be ok, its maxed at 2amps. i would either try another lipo or try a friends charger with a display to see cell voltage if at all possible. those lipos shouldnt have been damaged unless charger didnt shut off when fully peaked. if you cant get another traxxas lipo then get a spc 3s lipo alot cheaper than trx but its up to you.
    DEU 8:18 ESV

  9. #9
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    Yea i Accidently put 3 amp in my original post ......So the battery i got now should not be damaged? But wont charge still. i put it on a volt meter it reads 2.77v but turns truck on the shuts right back down?...shouldnt it charge?

  10. #10
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    well thats below the recommended level for sure of 3.0v lowest. set the charger lower at 1amp. keep an eye and if it still doesnt work then i would use a nimh charger for like a couple mins to get the voltage back up for no more than 3-5mins, this should get the voltage back up above 3v and let you charge it then on the lipo charger.
    DEU 8:18 ESV

  11. #11
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    how long @ 1 amp? With the battery being below 3.0v will that keep it from taking a charge?
    Last edited by e-revoPCB; 03-20-2012 at 01:33 AM.

  12. #12
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    it more likely will, try a standard nimh charger for about 5mins as stated to get voltage back up and then stick it on your charger it should work.
    does sticking it on the charger at 1amp on lipo charger work now?
    DEU 8:18 ESV

  13. #13
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    I had it on there for about ten min it went to 3.06v i put on nimh charger less than 1 amp for 5 min now....

  14. #14
    RC Racer
    Join Date
    Feb 2012
    Posts
    212
    bahahaha it worked took it off after 5 min 10.0v so now do i put it on the charger 2 amp of run it or what...... from now on how long should i charge a 3s 11.1v 1400mah battery for??? Thanks for the help!!!!!!!

  15. #15
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    well you want to charge it till the charger says its peak charged, couldnt find info if your charger has that feature or not. read your manual and see if it has that feature if it does then it should turn off. you want the cells to be balanced evenly on every charge. if ever your lipo charger doesnt want to charge your lipo then stick it on a nimh charger for only a couple mins to bring voltage back up, but if it happens often then your lipos are bad and i personally wouldnt use them then. you could try and contact traxxas about the lipos but i dont think they will replace them since they were not proporly charged. if i were you i would get a charger that has a peak charge cutoff and a display to see the voltage of the lipo, as you want a fully peaked 2s 8.4v-4.20v per cell, 3s 12.2v? 4.20v per cell also. and so on, the lipos get about 1v over the rated they are on total voltage like a 2s 7.4v lipo will be full at 8.4v. a cheap charger that works is thunder ac6. i got one and works good for the money, its not high end like alot out there but gets the job done good. look at hobbypartz.com for it.

    if you charge your 3s lipo 1400mah on a charge rate of 2amps then it would take like 30-40mins or so. i dont know how to figure that good yet on math for lipos. but its faster than the 1c 1.4amps standard rate.
    DEU 8:18 ESV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •