Results 1 to 5 of 5
  1. #1
    RC Champion
    Join Date
    Oct 2011
    Location
    Worcester, Massachusetts
    Posts
    1,396

    Castle 2400 is in and have a slight problem and a question

    I installed it and its all ready to go except i have a pinion problem, i cant get the set screw to thread and go all the way to the shaft, and yes its the right set screw. BTW what is my speed, ill be running 21/50 on 3s.
    SL4SH Mamba Monster-Rustler Mamba Max 2400kv

  2. #2
    RC Turnbuckle Jr. thedreadedend's Avatar
    Join Date
    Jun 2010
    Location
    Springfield, Ma.
    Posts
    3,359
    I've had a few that were a bit difficult. If it looks like the threads are all clear, no burs or recked threads, then take it off and in your hand and give it a shot of lube. Now screw it in all the way it allows, then back off turn, then tight to get a bit further in, then turn out, back in a bit further..... see if you can slowly and easily work the grub in there. While doing this, don't over do it. Just a bit at a time.
    I'm not a hatchet man! I'm a maggot!

  3. #3
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    21/50 on 3s with stock sized tires will be around 51 mph

    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  4. #4
    RC Champion
    Join Date
    Oct 2011
    Location
    Worcester, Massachusetts
    Posts
    1,396
    i ran 19/54 in my stock VXL on 3s, it seemed like it screamed. hopefully the 2400 will be like that
    SL4SH Mamba Monster-Rustler Mamba Max 2400kv

  5. #5
    RC Turnbuckle Jr. thedreadedend's Avatar
    Join Date
    Jun 2010
    Location
    Springfield, Ma.
    Posts
    3,359
    Sorry, wrong thread.
    Last edited by thedreadedend; 03-18-2012 at 02:59 AM.
    I'm not a hatchet man! I'm a maggot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •