Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Mar 2012
    Posts
    2

    stampede vxl electronics issue

    I was running my stampede the other day and hit a tire on a trailer. After that the RC didnt move at all. The steering at the time worked but no forward or reverse movement. I turned everything off and tired it again and the wheels turned hard right but no forward or reverse. Ive reset the controller to default, no luck tried to reset the esc but its like it doesnt get a signal. when I removed the servor and power up the esc the server just spins wide open and I cant control it with the controller. Ive plugged the servo into other channels on the reciever and it does the same thing. Just wondering if I have a servo issue or reciever issue.

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    Sounds like a servo issue
    Try unplugging it to see if you have control of the ESC back.
    Whatever it is I just typed... could be wrong.

  3. #3
    RC poster
    Join Date
    Mar 2012
    Posts
    2
    I tried that and I cant get the esc to respond to the calibration. I put new batteries in the transmitter and fully charged the battery pack.

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    I think it might be time to call Traxxas...
    Whatever it is I just typed... could be wrong.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •