Results 1 to 9 of 9
  1. #1
    RC poster
    Join Date
    Mar 2012
    Location
    Edmonton, Canada
    Posts
    4

    My 1/16 E Revo won't go forward.

    I just fixed my e revo's knuckles and when I went to test drive it the car didn't move like it had its own
    Feelings and didn't want to go. When I turn it on the light on the esc blinks red and green really fast.
    Any help please?

  2. #2
    RC Qualifier
    Join Date
    Jun 2010
    Location
    Lancaster PA....... NO i'm not Amish
    Posts
    321
    If you have the VXL car it's saying according to the manual that your esc is over voltage protection and it will cut power to the motor. What is you battery setup?

    page 17
    http://traxxas.com/sites/default/fil...l_100205_0.pdf
    MERV VXL + Rally VXL + Stampede Xl5

  3. #3
    RC Champion
    Join Date
    Feb 2012
    Posts
    1,717
    Is it in lipo mode?

  4. #4
    RC poster
    Join Date
    Mar 2012
    Location
    Edmonton, Canada
    Posts
    4
    I really don't know I just got it and I don't know much about cars. I know that I might have charged longer than I should have and i have 2 batteries in it that might be over chargerd

  5. #5
    RC poster
    Join Date
    Mar 2012
    Location
    Edmonton, Canada
    Posts
    4
    No as I said I don't know much about rc cars.

  6. #6
    RC Champion
    Join Date
    Feb 2012
    Posts
    1,717
    Are you hooking them up in parallel or series?

  7. #7
    RC poster
    Join Date
    Mar 2012
    Location
    Edmonton, Canada
    Posts
    4
    i dont have a vxl. i have a brushed motor and have the batterys in parallel.

  8. #8
    RC poster
    Join Date
    Jan 2012
    Posts
    14
    Yeah the batts are nimh, in parallel (double life, not double voltage) the esc got replaced under warranty, car has 2 hours on it and is like new.

    When the old esc went bad it just took off when turned on. Now it steers, but the motor makes no sound and wont go.

    This is NOT A VXL its his first car.

    It blinks very fast red. When turned on it is solid red, once the trigger is touched it starts blinking fast

    EDIT - when only one batt is on it works fine. Sounding like you overcharged you expensive toy kiddo . Take better care of your toys and read your instructions. Mom and i arent made of money i did your homework for you, so now you will need to discharge those batts one at a time and charge em properly. Maybe ask mom and i what work we have to earn a smart charger unit? I have firewood to cut amd some truck repairs i could use extra hands with.


    Thanks for the help guy who mentioned overvoltage - you got me thinking and testing and the problem is sorted out.
    Last edited by ohsofly; 03-12-2012 at 03:36 PM.

  9. #9
    RC Champion
    Join Date
    Jan 2012
    Location
    Ontario
    Posts
    1,395
    hahah, easy fix, I did something similar when I first got mine..

    was just running it though and my truck wouldn't go forward just backwards, for almost a full minute then it just decided to go forward again..

    what causes that??
    6.25% /

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •