Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Feb 2012
    Posts
    5

    why aren't my batteries charging?

    hey guys,

    so I recently got the revo 3.3, which i havent used in the last month due to the weather. its been raining
    for the last month. so today i had plans to take the car out as it was sunny, but thought ill charge the
    batteries first, ive got the 5-cell NiMH and the EZ start 6-cell batteries which came with the revo package.

    My question is the batteries have been charging for about 9-10hrs straight and the red light on the
    chargers havent turned green. When i switch the charger off it turns green but when i plug the batteries in the stock chargers that came with the car it goes to red saying its not charged.

    do I need to charge them longer since I havent touched them in over a month? the 5-cell gets pretty warm when its charging.

    any help/info would be great.

    thanks

  2. #2
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,840
    if its warms then its done charging, it should be full charged. try it on the revo after charging and see if the servos move fast. try it before charging again or you'll burn the battery out.
    DEU 8:18 ESV

  3. #3
    RC poster
    Join Date
    Feb 2012
    Posts
    5
    thanks for that.

    got it all sorted. got bigger problems now. misjudged a jump and now have a bent chassis, and now it wont start. :-(

  4. #4
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,840
    man that is bad, havent heard too many say they bent the chassis's. they are kinda thick and hard to bend you must have been going fast to do that. time for a new chassis now.
    DEU 8:18 ESV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •