Results 1 to 7 of 7
  1. #1
    RC Competitor
    Join Date
    Dec 2011
    Posts
    61

    Will this servo work

    I have a hitec hs-7955tg servo and I'm wondering if I can use this in my e revo with the mamba monster esc. I would just use the single servo and I'm running 4s lipo

    Sent from my DROIDX using Tapatalk

  2. #2
    RC Turnbuckle Jr. Cameron's Avatar
    Join Date
    May 2009
    Location
    Edmonton, Alberta
    Posts
    3,604
    i ran a 7955tg on my conversion, worked awesome once i added the capacitor.
    (RAH) (AH) + [ROMA (1+MA)] + (GA) + (OOH)(LA)

  3. #3
    RC Competitor
    Join Date
    Jan 2012
    Posts
    78
    That is a great servo I have one in my e-revo. Make sure you get the servo horns for aftermarket servos part number 5345X unless you have a different horn in mind.

  4. #4
    RC Competitor
    Join Date
    Dec 2011
    Posts
    61
    I ask cause my brother had this in his savage 2450 but it would glitch. I know his doesn't have the mamba monster and I really don't want to add a bec

    Sent from my DROIDX using Tapatalk

  5. #5
    RC Turnbuckle Jr. Cameron's Avatar
    Join Date
    May 2009
    Location
    Edmonton, Alberta
    Posts
    3,604
    i added just a spektrum capacitor that plugged direct in to an open plug on the RX. cost like $12 iirc.

    fixed the glitching as soon as it was plugged in, haven't had any issues since.
    (RAH) (AH) + [ROMA (1+MA)] + (GA) + (OOH)(LA)

  6. #6
    RC Competitor
    Join Date
    Jan 2012
    Posts
    78
    what do you guys mean by glitch? like the wheels were twitching? I have one in my ERBE and it doesn't glitch at all, the MM has a BEC as far as I know.

  7. #7
    RC Turnbuckle Jr. Cameron's Avatar
    Join Date
    May 2009
    Location
    Edmonton, Alberta
    Posts
    3,604
    yeah when it turns on before you go anywhere the front wheels will start twitching or the servo will hum and try to center itself over and over. In my conversion, i thought it just wasn't centered so i took the horn off and it kept on going. added the cap and it went away. that was a MMM 2200kv on a 5s lipo. I understand it isn't a "its always gonna happen" kind of thing. just speaking from personal experience.
    (RAH) (AH) + [ROMA (1+MA)] + (GA) + (OOH)(LA)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •