Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Feb 2012
    Posts
    8

    Receiver & Transmitter problems

    Hey there! I am having an issue with my traxxas Link receiver and the 2.4gz transmitter. I was driving my rally in my basement when all of the sudden the car braked and I lost control. I took of the body to find the link receiver blinking between green and red lights very fast.

    I looked in the manual and thought that It may be a problem with the bind. And so I tried to re-bind the system but when I do the steps:

    Hold set, then turn on transmitter. (red light blinks slow)
    Hold link, then turn on esc.


    I get a green light on my transmitter, with a slow blinking red light on my receiver. I have let this go on for about 10 minutes and the problem still stands. I also have a green light on the ESC


    Anyone know what I can do? I've read everything in the book and I can't call traxxas support because I live in Canada.


    Much appreciated!

    Little update, I have been searching some old posts and some people find that it is because the steering servo is broken. I tried to do a bind without the servo plugged and and it worked fine.
    Last edited by cooleocool; 02-16-2012 at 04:13 PM. Reason: post merge

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    Awesome! Glad you got it under control!!

    Let us know if you need help finding a replacement.
    Last edited by JimmyNeutron; 02-14-2012 at 08:34 PM.
    Whatever it is I just typed... could be wrong.

  3. #3
    RC poster
    Join Date
    Feb 2012
    Posts
    8
    Turns out the servo fried and that was what caused the lack of reply between receiver and the transmitter. Threw a new servo in there and everything worked just great! While I was reading up on that problem I seam to find that this is a problem that occurs quite often with these servo's so a few suggestions for a better replacement would be awesome!

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,291
    Here is a list of servos... keep in mind not all of them are an upgrade:
    http://www.servodatabase.com/compare...1677,2119,2130

    I chose the ******* 390 (same as a blue bird 390) for my two 16ths.

    IF you go the 390 route, here is how to set it up:
    390 Set Up

    All stock hardware is used.
    NONE of the hardware included is needed!


    There are tab braces that do not allow the servo gaurd to sit flush.
    IT IS OPTIONAL TO REMOVE THEM.
    I have done this both ways without any adverse reactions.
    Here is a picture of the braces:

    The only reason this may need to be done is because of the small gap between the chassis and the servo gaurd.


    You will also need to reverse the servo direction.
    These are the steps to follow to do so:
    (Traxxas LINK)

    Hold MENU
    Green Blinks

    Press MENU
    2 Green Blinks

    Press SET
    Green Blinks

    Press SET
    Red Blinks

    Press SET
    8 Green Blinks

    Hold MENU
    Setup Complete
    Whatever it is I just typed... could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •