Results 1 to 4 of 4
  1. #1
    RC Racer
    Join Date
    Jan 2010
    Posts
    164

    Problem with MMM Fan? Help please

    Hello wise ones

    My ERBEs fan always used to run all the time. Recently it does not. It whirs on startup as it does the battery check and beeping, but then stutters to a stop when the car is ready to go.

    I'm worried if this is a problem or not, and if the car will overheat

    Thanks for any help

  2. #2
    RC Qualifier
    Join Date
    Mar 2007
    Location
    ashburn, VA
    Posts
    569
    I know at least for mine, the fan only runs if needed. if yours used to run all the time then you might have had a problem from the begining. at least if it comes on when you plug in the battery you know the fan works, your ESC may have an issue with the fan activation circuit.
    REVO 3.3, shumacher fusion .21,TC4, ERBE

  3. #3
    RC Racer
    Join Date
    Nov 2011
    Location
    SoCal
    Posts
    114
    Mine spins up on start then stops.

    It only runs when I have been driving it hard.

  4. #4
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,819
    like stated the fan runs during start up & will only come on when the ESC temp is above150 *F... Then when the ESC temp drops below 150 it will shut back off.
    Would you go flip my truck back over??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •