Results 1 to 12 of 12
  1. #1
    RC poster
    Join Date
    Feb 2012
    Posts
    5

    2nd Day with New Revo 3.3, clutch issues

    I'm on my 2nd day with my new Revo and broke it in properly. I noticed during break in that it was slow to get moving off the line.
    Today after tuning and some off road driving the stock clutch was missing 2 of the 3 pads. I went to my LHS and picked up the Traxxas heavy duty clutch rebuild kit. I tightened the nut enough to bend my Allen wrench and still it seems to slip off the line and at higher speeds??
    Last edited by HB; 02-07-2012 at 07:27 PM.

  2. #2
    RC Competitor
    Join Date
    Jan 2012
    Posts
    78
    You are talking about your slipper clutch correct? If you are, you sure you aren't talking about the nylon nut that you tightened. The best thing I have found and read is to tighten it all the way and back it off about a half turn. I am using the aluminum pads, or whatever material they are. It is working great for me.

  3. #3
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Simi Valley, CA
    Posts
    499
    There are concave washer on the slipper clutch - they should go on like this < >

    If you over-tighten them you can ruin them and they don't work right. You should not be cranking that nut down tight like that. Just tighten only until it is hard to move the spur when you have a driver holding the shaft at the other end. There is a hole in the shaft that you can but a driver through while you tighten the nut. Then hold the shaft in place and make sure you can still move the spur, with some effort and digging into your hand, on the slipper clutch.

  4. #4
    RC poster
    Join Date
    Feb 2012
    Posts
    5
    Thanks. I put the washers on like you mentioned and followed the directions for tightening the nut. I had no resistance on the spur until it was super tight, which bent my Allen wrench that was in the hole on the shaft.
    I'm using the metal (aluminum pads?)

  5. #5
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Simi Valley, CA
    Posts
    499
    Something is wrong with that setup, you should be able to adjust between no resistance and locked in place. Those aluminum pads should be biting really well - very aggressive.

  6. #6
    RC poster
    Join Date
    Feb 2012
    Posts
    5
    Thanks for the help.
    I guess I will pull the engine back out and try again. The nut is so recessed that I can't adjust with the engine back in place with the supplied 8mm

  7. #7
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Simi Valley, CA
    Posts
    499
    Never mind - thought I might have an idea of what it could be but that's not it.
    Last edited by Jake C6R; 02-07-2012 at 08:45 PM.

  8. #8
    RC Champion
    Join Date
    Mar 2011
    Location
    Delta, Pa.
    Posts
    1,833
    Take a look at the aluminum bracket that the slipper pads mount to. Also check to make sure the bell washers are not crushed. And I know this sounds stupid, But if your tensioning nut is that far rescessed. Is the bearing in place/damaged?

  9. #9
    RC poster
    Join Date
    Feb 2012
    Posts
    5
    I will check the bearing. I didn't disassemble the spur assembly so that should be good.

  10. #10
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,675
    The lettering of the spur should be facing the engine. If not, then it is flipped around. You should have easy access with the 8mm wrench from the top or sides to get to the nut.
    The Super Derecho

  11. #11
    RC Champion
    Join Date
    Mar 2011
    Location
    Delta, Pa.
    Posts
    1,833
    Quote Originally Posted by Double G View Post
    The lettering of the spur should be facing the engine. If not, then it is flipped around. You should have easy access with the 8mm wrench from the top or sides to get to the nut.
    Thats what I was also thinking. Something is deffinatly wrong with how the assembly is installed if the tensioning nut is recessed. I can remember back in the days of new crushing the web and it slipping like described. But the nut being recessed has me baffled. He mentioned that he bent his allen wrench when tightening. The web would deffinatly break under that kind of force wouldnt you think. Its a shame I cant look at mine. I changed to a different manufactures design to get the steel spur. That design uses a disk instead of pads.
    OP, Good luck and dont become discouraged. The revo is a great truck. I see sooo many people loose there cool on it. The revo can be challanging at times. Thats why its not a level 1 model.

  12. #12
    RC poster
    Join Date
    Feb 2012
    Posts
    5
    Update! Clutch issues resolved!

    First of all, thanks for all of the help and quick replies.

    In my haste to get it back together I left the bearing out for the pressure plate.
    The new heavy duty slipper pads are great. The slipper was so loose out of the box it was not shifting in to high gear. I didn't even realize this until today when testing it out after reassembly. After a hsn and lsn tune I'm popping small wheelies off road with stock shock settings.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •