Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Jan 2012
    Posts
    15

    Need Help Please!!

    Hey RC friends, I purchased a Slash VXL on 1/13/12 and am having a serious problem. My friends and I built a short course in my back yard and were running today when I noticed that my batteries weren't lasting as long. I thought it was because I just had purchased the ESC fan. However after about 3 battery runs my truck started making a screach sound.I took the cover off and thought it was the clutchs, ran to hobby store and got a new clutch setup. Installed that and with cover off turned on car and still same problem. My friends and I could hear the motor turning but the pinion was not. We check to make sure nothing was binding up in spur or pinion. The gears have no broken or shaved teeth. Checked the set screw on the pinion gear to ensure that it was tighten down, it was. Then when the motor is spinning every once in a while it catches and moves the truck. I removed the motor from its mounts and gave it some throttle and it sounds fine with no load on it. Installed back in truck and gave it throttle and still same. We checked transmission early in steps. With clutches removed and wheels on the ground I could turn shaft and wheels would move, with someone holding the wheels I could not turn shaft. So that checked out according to what we had read. This truck has not been thrashed (wife would thrash me!) So I bought Traxxas because everyone said they're good and pretty hard to break. I did the maintenance according to the manual. Now I sit here with a truck that won't move! Anyone know or have ideas to fix?
    Thanks in advance,
    Eddie
    Also I have youtube page "Driftindaddy" that will have the course we built in last week so you can see we're not out to destroy our vehicles. New footage should be up in hour or so.

  2. #2
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    El Sobrante, Ca
    Posts
    7,449
    It is a common problem. The magnet came loose from the shaft in your motor. There is a rebuild kit that Traxxas sells. If you call Traxxas support, they may replace the motor for free under warranty. At some point you might have over heated the motor.
    Slash Ultimate, ET-3S, 2400, MIP, King Headz, RPM

  3. #3
    RC Qualifier
    Join Date
    Oct 2011
    Location
    MISSOURI
    Posts
    390
    sounds like the magnet let loose in the motor . take the motor apart if the magnet spins on the shaft there it is. call traxxas they will send u a new one , but ya she shouldnt of let go on ya unless u overheatn it.
    EFFORT EQUALS RESULTS

  4. #4
    RC Qualifier
    Join Date
    Oct 2011
    Posts
    427
    off topic, but make some vids of the track!

  5. #5
    RC poster
    Join Date
    Jan 2012
    Posts
    15
    It should be uploaded to my youtube page, however we did add more to track, like bigger berms and fixed a couple jumps. The uploaded videos I just uploaded are from today and after my Slash went down we went a round the track and fixed it up. It is a short track but wide and fun for a while. Check my page @ Driftindaddy on youtube.

  6. #6
    RC poster
    Join Date
    Jan 2012
    Posts
    15
    Thank you guys for your help since I'm new or renew to RC cars and am new to Traxxas. As to the over heating not sure how I did that on this track and messing around in the back yard. If you watch videos on my YouTube page you will see I'm not big on destroying my equipment.

  7. #7
    RC Racer
    Join Date
    Apr 2011
    Location
    Rochester, NY
    Posts
    163
    Exact same thing happened to my friend and I ...same time...Contacted traxxas, sent them in, they gave us 2 new motors for free!!!!...

    In the future check your motor with your hand and make sure you can touch it for 30-60 secs, if not let it cool before running a new battery.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •