Results 1 to 4 of 4

Thread: reverse problem

  1. #1
    RC poster
    Join Date
    Jan 2012
    Posts
    2

    reverse problem

    Hi, today I had a problem with the reverse of my summit. It just won't work! Everything else is fine and runs ok, brakes do work (so not a transmitter problem) but reverse don't... Tried reprogramming the esc in sport profile, but no result. Listening closely close to the esc I can hear a low electronic noise come out from the esc (or so it appears) when I apply the reverse...
    Any suggestions?

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    ESC could be faulty.
    If you are in the states, call Traxxas.
    If within warranty (sometimes even if you are not) they will replace it for free.
    Whatever it is I just said... I could be wrong.

  3. #3
    RC poster
    Join Date
    Jan 2012
    Posts
    2
    Yes, I imagined that, strange that it happened when everything was working fine... Can it be I burned something in the esc that doesn't affect anything else, just the reverse?

  4. #4
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    Possible. I have not opened the ESC up to see the circuitry.
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •