Page 11 of 13 FirstFirst ... 910111213 LastLast
Results 401 to 440 of 485
  1. #401
    RC Competitor
    Join Date
    Mar 2014
    Location
    rocheser ,ny
    Posts
    51
    Blew my shock cap off. My wife moved the shock components and oil so I can't fix. and i just installed my new tires
    Last edited by darthkoolaid78; 04-16-2014 at 03:58 PM.

  2. #402
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Bad Landing on the Wheelie Bar. Screw spripped. Also did my first couple of front flips today. So cool!!!


  3. #403
    RC Competitor
    Join Date
    Mar 2014
    Posts
    62
    My diff was definitely jacked up a little. The 5118 and 5119 bearings were bad, and the slop allowed the gears to move enough that they weren't messing very well, so they chewed each other up a little bit. The planetary gears show no signs of wear, but the other ones on the diff outputs are a bit knackered. The ring gear is chewed up some too... don't know how well you can tell from my phone pic.

    Anyway... diff cup and XO-1 gears should arrive today, and hopefully the LHS has the bearings. I want to run this weekend!!!

  4. #404
    RC Competitor
    Join Date
    Feb 2014
    Location
    Arkansas
    Posts
    76
    Took off after installing the rear MIPs and couldn't come down from a wheelie fast enough to avoid a street sign.

    Ignore my child, hes gotta work on anything his daddy works on.




    Last edited by Cassperr; 04-17-2014 at 01:35 PM.

  5. #405
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Ok I should't do any more front flips at that bashing spot.

    So is it worth getting RPM Arms? Can I use the Shock guards together with them?

    Should I also replace the rear bearing carriers?

    Last edited by soundmaster; 04-18-2014 at 07:06 AM.

  6. #406
    RC Competitor
    Join Date
    Mar 2014
    Posts
    62
    Shock guards fit RPM arms. They're nice, very flexible. I put RPM arms on mine as one of the first few upgrades. They've been great.

    I haven't broken a bearing carrier yet, but if I do, I'll replace them with RPM.

  7. #407
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    719
    Quote Originally Posted by soundmaster View Post
    Ok I should't do any more front flips at that bashing spot.

    So is it worth getting RPM Arms? Can I use the Shock guards together with them?

    Should I also replace the rear bearing carriers?

    I have broken two rpm a-arms in the same spot after crashes with static objects. So just because you put on rpm arms doesn't mean that breaking at the hinge pin won't happen again...
    The message above or below may or may not be true

  8. #408
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Quote Originally Posted by Hirschowl View Post
    I have broken two rpm a-arms in the same spot after crashes with static objects. So just because you put on rpm arms doesn't mean that breaking at the hinge pin won't happen again...
    True. Since my local hobby shop got some stockers in stock I will get them tomorrow.

    I never had issues with the stockers for over 2 years now, but those front flips at full speed with bad landing is just too much for every part so I will skip that for the next runs.

  9. #409
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,628
    I am still on stock rear carriers and they have taken crazy abuse in over three years dude but people who have bust the stock one's say the rpm ones are virtually bulletproof but I have to take their word.......peace
    Famous last words...watch this!!!!

  10. #410
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Front Flips are taboo for me now. Risk is just too high to break something on every bad landing.

    I will keep doing backflips and huge normal jumps that I can land perfectly.

  11. #411
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    719
    Problems with Front Tekno axle again. This time the drive output cup came off. The screw/pin must of backed out. I do put blue loctite on all metal to metal, and check them often. Must of over looked it. By shear luck again, (I never get lucky) I was able to find the output cup in my backyard and the dog bone was still attached via pin and barrel. Able to use the same pins for the traxxas driveshaft ouputs, the are just a bit shorter. Thinking some MIP's might be headed my way, and will probably sell the teknos.

    I have tried to contact Tekno support earlier this week via phone and e-mail with NO response to either voice message or e-mail. Not very good customer support...and not a happy customer, but still good luck the the center drive shaft!!!
    The message above or below may or may not be true

  12. #412
    RC Turnbuckle Jr. billy-bones's Avatar
    Join Date
    Nov 2012
    Location
    Michigan
    Posts
    5,245
    I have tried to contact Tekno support earlier this week via phone and e-mail with NO response to either voice message or e-mail. Not very good customer support...and not a happy customer, but still good luck the the center drive shaft!!!
    This doesn't sound like tekno, I run them on my 2wd and 4wd slash trucks and have for a long time, so far my luck has been outstanding and I never loctite anything.
    Hope you get it figured out, best of luck to you.
    Built Ford Tuff With Chevy Stuff.

  13. #413
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    719
    Quote Originally Posted by billy-bones View Post
    This doesn't sound like tekno, I run them on my 2wd and 4wd slash trucks and have for a long time, so far my luck has been outstanding and I never loctite anything.
    Hope you get it figured out, best of luck to you.
    Maybe they are swamped with calls and e-mails, and an early week due to Easter? I haven't really heard of any bad storys about tekno products or support, but I have a bad story in the making. I hope this story has a happy ending...
    The message above or below may or may not be true

  14. #414
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Nothing Yeahhhhhhhhhh!!!!

    But no front flips anymore

  15. #415
    RC Competitor
    Join Date
    Mar 2014
    Location
    rocheser ,ny
    Posts
    51
    finally broke a shaft bashing

  16. #416
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Wanted to try 4s today:


  17. #417
    RC Qualifier
    Join Date
    Feb 2014
    Posts
    293
    Quote Originally Posted by soundmaster View Post
    Wanted to try 4s today:

    I've been wondering what 4s is like on the pede. Looks like an axle snappin good time. Or is that the drive shaft? Ive never had mine apart.
    Last edited by roscoeP; 04-20-2014 at 06:54 AM.

  18. #418
    RC Qualifier
    Join Date
    Mar 2012
    Posts
    575
    That's the slipper shaft.

  19. #419
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    I will stay on 3s. 4s is just too much carnage.

  20. #420
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,628
    Dude you can see in the pic that was way to tight put the revo slipper setup back on and run it about 1 full turn from tight and you should be all good some of my buddies run the 2200kv on 4s with no problems and they bash like it's not theirs trust me..........peace
    Famous last words...watch this!!!!

  21. #421
    RC Qualifier
    Join Date
    Feb 2014
    Posts
    293
    Quote Originally Posted by soundmaster View Post
    I will stay on 3s. 4s is just too much carnage.
    I can hardly control 3s on mine when i get on it good. Squeeze it full and she gets all squirrly in the grass, my lawn is not flat. Have yet to break anything but axels, after mips all good.

  22. #422
    RC poster
    Join Date
    Oct 2013
    Location
    WV
    Posts
    4
    Well 45 seconds in the hands of the 5 year old nephew... Rpm arms are now on the way and maybe some socks on further investigation

  23. #423
    RC Qualifier
    Join Date
    Feb 2014
    Posts
    293
    Quote Originally Posted by MancheUSMC View Post
    Well 45 seconds in the hands of the 5 year old nephew... Rpm arms are now on the way and maybe some socks on further investigation
    My wife keeps asking me "why dont you give Austin (my nephew) a try?" I should show her your post.

  24. #424
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    719
    Surprisingly nothing on the P4de. My nephews did break my sons little redcat tremor, which doesn't suprise me. My Venom 3s battery is giving me serious balancing issues. Wanting to get rid of this battery, but waiting on SPC for more 3s battery stock...
    The message above or below may or may not be true

  25. #425
    RC Qualifier
    Join Date
    Jun 2012
    Location
    nevada, mo
    Posts
    288
    I broke a rear drive shaft.

  26. #426
    RC Qualifier
    Join Date
    May 2009
    Posts
    364
    Absolutely nothing. Hard to break stuff in the middle of a build lol. Got parts coming and it should be up and running soon.
    E-Maxx 3905 and 3906. :D

  27. #427
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Quote Originally Posted by spenniepoos View Post
    Dude you can see in the pic that was way to tight put the revo slipper setup back on and run it about 1 full turn from tight and you should be all good some of my buddies run the 2200kv on 4s with no problems and they bash like it's not theirs trust me..........peace
    Yes slipper was set too tight!

  28. #428
    RC Racer
    Join Date
    Jan 2014
    Posts
    220
    MIPS thrown and gone. Guess they losened up even with blue loctite! Lost the first one (the little barrel like piece with the pin thru it was gone allowing the part off the diff to seperate from the splined shaft that was still inside the other one). Since all the other parts there I thought it was no big deal. Looked over the other screws, threw in my last remaining stock shafts and not too much longer was 2wd again! This time I threw (and lost somewhere) the entire inside components from the differential side in the front. All I have left is the hub and shaft the splined parts used to g o into (grrrr).

    Went to Ebay and got a new set on the way. Should leave me a few spare parts I hope won't ever need. Thniming I might use red loctite. Question about the blue though. I've seen stuff come with it on the threads already. The instructions say to apply it to the threads, screw it in and it will ne set in 10 mins, cured in 24 hours. How are you guys applying it? What about the red? Do i really need red?
    Last edited by IPT; 04-22-2014 at 03:17 AM.

  29. #429
    RC Turnbuckle Jr. spenniepoos's Avatar
    Join Date
    Apr 2012
    Location
    Wales in the UK
    Posts
    5,628
    Yes just use it sparingly after a good clean with alcohol and let sit for 24 hours .......peace
    Famous last words...watch this!!!!

  30. #430
    RC Qualifier
    Join Date
    Feb 2014
    Posts
    293
    +1 on red loctite. I use it and have not had any problems. A little heat works to get it back apart if you have trouble.

  31. #431
    RC poster
    Join Date
    Jan 2014
    Posts
    17
    what did I break today?...lots..but not till it jumped over and out of the fence at the skate park, all of those HUGE jumps were without breakage, but a curb at full speed caused a broken front diff carrier, bulkhead, chassis, center driveshaft, and tie rod on servo to break. does anyone know of an upgraded main chassis? if not, I will have to get a stocker and dye it

  32. #432
    RC Qualifier
    Join Date
    Sep 2012
    Location
    Liverpool, New York
    Posts
    541
    Quote Originally Posted by christopher.franssen View Post
    what did I break today?...lots..but not till it jumped over and out of the fence at the skate park, all of those HUGE jumps were without breakage, but a curb at full speed caused a broken front diff carrier, bulkhead, chassis, center driveshaft, and tie rod on servo to break. does anyone know of an upgraded main chassis? if not, I will have to get a stocker and dye it
    Ouch! Got any pics of the damage?
    Just Bash it!
    4x4 Pede
    Two 2wd Pede

  33. #433
    RC poster
    Join Date
    Jan 2014
    Posts
    17
    no i dont have pics of the damage i almost thought it survived the curb hit because it was being held in position by the body but the whole front end is completely separated from the rest of the truck

  34. #434
    RC Qualifier
    Join Date
    Dec 2013
    Location
    Starr County, Texas
    Posts
    680
    MIP.
    Lost grub screw from diff shaft and lost flat pin from splined shaft half.




    Sent from my neXus⁴ using tapatalk 2
    <P4de VXL|Castle 3800kv|MM2|MIP|STRC|Proline|SPC>

  35. #435
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Quote Originally Posted by 1SlowTRX View Post
    MIP.
    Lost grub screw from diff shaft and lost flat pin from splined shaft half.




    Sent from my neXus⁴ using tapatalk 2
    This is a classic. Did you use red or blue loctite?

  36. #436
    RC Qualifier
    Join Date
    Dec 2013
    Location
    Starr County, Texas
    Posts
    680
    Quote Originally Posted by soundmaster View Post
    This is a classic. Did you use red or blue loctite?
    Blue like it said in the manual. But after reading here I should of used red haha

    Sent from my neXus⁴ using tapatalk 2
    <P4de VXL|Castle 3800kv|MM2|MIP|STRC|Proline|SPC>

  37. #437
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,781
    Quote Originally Posted by 1SlowTRX View Post
    Blue like it said in the manual. But after reading here I should of used red haha

    Sent from my neXus⁴ using tapatalk 2
    since i use red on all mip grubs, including the ones for the 17mm adapters no issues anymore.

    also easy to remove with soldeing iron.

    thanks again spennie for this advice.

  38. #438
    RC Qualifier
    Join Date
    Dec 2013
    Location
    Starr County, Texas
    Posts
    680
    Quote Originally Posted by soundmaster View Post
    since i use red on all mip grubs, including the ones for the 17mm adapters no issues anymore.

    also easy to remove with soldeing iron.

    thanks again spennie for this advice.
    I'll give that a try once I get the parts again. How do you use the soldering iron to get them off? Just put it against the grub until it heats up?

    Sent from my neXus⁴ using tapatalk 2
    <P4de VXL|Castle 3800kv|MM2|MIP|STRC|Proline|SPC>

  39. #439
    RC Qualifier
    Join Date
    May 2013
    Location
    Erie, PA
    Posts
    719
    Quote Originally Posted by 1SlowTRX View Post
    MIP.
    Lost grub screw from diff shaft and lost flat pin from splined shaft half.

    Use some thru pins on the diff output. Much stronger than two grub screws pinching the diff output shaft, and only one set of threads to worry about. Part #'s. HPI #86094 or Traxxas #5145...
    The message above or below may or may not be true

  40. #440
    RC Qualifier
    Join Date
    Dec 2013
    Location
    Starr County, Texas
    Posts
    680
    Quote Originally Posted by Hirschowl View Post
    Use some thru pins on the diff output. Much stronger than two grub screws pinching the diff output shaft, and only one set of threads to worry about. Part #'s. HPI #86094 or Traxxas #5145...
    Thanks and yeah I had those in mind, but traxxas #5189 instead. They're 2mm shorter and 1mm past the MIP knuckle, not sure if the 5145's are too long or not.

    Sent from my neXus⁴ using tapatalk 2
    <P4de VXL|Castle 3800kv|MM2|MIP|STRC|Proline|SPC>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •