Results 1 to 9 of 9
  1. #1
    RC Enthusiast
    Join Date
    Dec 2011
    Posts
    24

    rustler lipo battery problem.

    today i went to drive my rusty so i put my lipo in turned on low volt detection and drove it did a wheelie or 2 for maybe a minute before the green light started flashing red. after that i tried to turn it off but it would not unless i unplug the battery it wouldnt even switch back to low voltage off. so i took out my lipo and put in my nimh and it worked fine so i figured i would try my lipo again so i put in the lipo switched to low voltage off and it went flashing red right away. does that mean my lipo is dead? Lol thanks for any input

  2. #2
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,210
    With the info you have given it certainly sounds like the issue MAY be with the lipo. Do you have a voltmeter or a balancer with a voltage read out on it so you can check the cell voltages on the lipo pack? That would tell you for sure. Your ESC may be hitting the LVC prematurely as well.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  3. #3
    RC Enthusiast
    Join Date
    Dec 2011
    Posts
    24
    i have a volt meter the lipo has not been charged before what number would i be looking for?

    6.117 dc volts im assuming its dc
    Last edited by johnpg21; 01-01-2012 at 02:26 PM.

  4. #4
    RC Racer
    Join Date
    Mar 2011
    Location
    Barksdale AFB, LA
    Posts
    159
    Quote Originally Posted by johnpg21 View Post
    i have a volt meter the lipo has not been charged before what number would i be looking for?

    6.117 dc volts im assuming its dc
    When you say it hasn't been charged before, do you mean you put a brand new lipo in without charging it or did you not charge it between using it and taking those readings?

  5. #5
    RC Enthusiast
    Join Date
    Dec 2011
    Posts
    24
    Quote Originally Posted by brett.schroder View Post
    When you say it hasn't been charged before, do you mean you put a brand new lipo in without charging it or did you not charge it between using it and taking those readings?
    without charging..i read the paper that i misplaced and it says not to o.o

  6. #6
    RC Racer
    Join Date
    Mar 2011
    Location
    Barksdale AFB, LA
    Posts
    159
    Lipos usually come partially charged, have you charged it? Do you have a lipo capable charger to charge and balance it?

  7. #7
    RC Enthusiast
    Join Date
    Dec 2011
    Posts
    24
    Quote Originally Posted by brett.schroder View Post
    Lipos usually come partially charged, have you charged it? Do you have a lipo capable charger to charge and balance it?
    no it came in before the charger i should be getting it tomorrow

  8. #8
    RC Racer
    Join Date
    Mar 2011
    Location
    Barksdale AFB, LA
    Posts
    159
    Yea just balance and charge it, that should get it going. I hope you have a lipo bag or ammo can to charge it in, I wouldn't leave it charging unattended.

  9. #9
    RC Competitor
    Join Date
    Nov 2011
    Location
    Yuma, Colorado
    Posts
    87
    Lol, that makes me laugh. Basically you said this "I just got this new lipo and I drove it a little bit then the low voltage thing came on OMG. I know like I haven't like charged it or anything, but like it keeps turning on low voltage detection like that battery is low on voltage or something."

    Thanks for the laugh bud, common sense would tell me that the battery probably needs charged, who knew!
    The low voltage detection just does that, you can't do anything other that watch the flashy light because it really doesn't wan't to over-drain the lipo, which could be fatal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •