Results 1 to 8 of 8
  1. #1
    RC Racer
    Join Date
    Mar 2011
    Posts
    106

    Is my servo dead?

    When I turn on my car, my receiver flashes red and green rapidly. It has no steering and the throttle is very jumpy and edgy. I unplugged the servo from the receiver and turned it on and it reacted normally, without steering of course. Does this mean my servo is shot? Anyone have an idea?

    Thanks

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,581
    Sigh. Yes .
    The Super Derecho

  3. #3
    RC Racer
    Join Date
    Mar 2011
    Posts
    106
    Thanks. It's alright. Should I upgrade to one with metal gears? I've heard people recommend that on either this one or the slash 4x4 one. I'm on both so they mesh in my head. Any suggestions on which one to get?

  4. #4
    RC Racer
    Join Date
    Mar 2011
    Posts
    106
    Someone recommended this one on another forum-******* tgy-390dmh. Any thoughts?

  5. #5
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,279
    I love my 390... wait no!

    i LOVE my 390!!

    Sorry, I just wanted to make that clear. lol

    The stock hardware bolts right on... all you really need to do is reverse servo direction in the Tx.
    Whatever it is I just said... I could be wrong.

  6. #6
    RC Racer
    Join Date
    Mar 2011
    Posts
    106
    Alright, you sold me on it. How do you reverse servo direction?

    Thanks for the help!

  7. #7
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,581
    Do you have the LINK or AM radio? If AM, just flip the switch of channel 1, otherwise look in the back of the manual on how to switch it with the LINK.
    The Super Derecho

  8. #8
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,279
    Hold MENU
    Green Blinks

    Press MENU
    2 Green Blinks

    Press SET
    Green Blinks

    Press SET
    Red Blinks

    Press SET
    8 Green Blinks

    Hold MENU
    Setup Complete
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •