Results 1 to 16 of 16
  1. #1
    RC poster
    Join Date
    Nov 2011
    Posts
    5

    6 amp charger website & specifics

    how come there is not any website for the traxxas 6amp charger and dose it come with a true lipo balencer

  2. #2
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    try amainhobbies they have it (not in stock) not sure about specs though and it should be a complete charger with lipo balancer built in. its blue from what the pic looks like.
    DEU 8:18 ESV

  3. #3
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,140
    Quote Originally Posted by tmaxx vs. emaxx View Post
    how come there is not any website for the traxxas 6amp charger and dose it come with a true lipo balencer
    The Traxxas TRA2933 EZ-Peak Plus 6-Amp Lipo/NiMH Battery Charger has not been released yet.
    It has a built in balancer.
    Alt-241 on the number pad =

  4. #4
    RC Champion
    Join Date
    Apr 2011
    Posts
    1,865
    I beleive its available in dec.

  5. #5
    RC Competitor
    Join Date
    May 2011
    Location
    Fremont,MI
    Posts
    78
    Looks like Towers has it in stock.

  6. #6
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    its in the traxxas product page now under chargers to see the specs on it. tower has this at 103 with a bit much for it only having 6amps max but what can you say it has a excellent warranty through traxxas. looking at getting something a little cheaper in the future for lipo's not too sure though. nice charger though.
    DEU 8:18 ESV

  7. #7
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    250
    Just got mine last Friday. I'm pretty new to this stuff, just basic 9.6V NiCd's in the past. Seems to be working fine. Charged my son's 7.2v NiMH for his Grave Digger and I'm charging my two 8.4's today for my Emaxx. Lipo's coming after X-mas for it. Makes a weird noise when the fan first starts up for about 15-20 sec., like it's warming up/checking things?!? Charging at a low rate just to get them fully charged. Chris
    FLM EMBE, P4de "Digger", Slash MT, Rustler/P4de

  8. #8
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,140
    Post a video (audio) of the "weird noise."
    Alt-241 on the number pad =

  9. #9
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    250
    I will try at lunch with my Iphone. It's like a GRR, pause, GRR pause, over and over, about 10 times, each time the fan seems to start to work then pause. At 20 sec, it's all fan, no issues after, sounds fine. Only does it at the first start up/plug in of the day. When I did the second battery, it didn't do it. So after it's done charging one of the batteries this morning, it might not do it this afternoon. Chris
    FLM EMBE, P4de "Digger", Slash MT, Rustler/P4de

  10. #10
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,140
    Does it sound anything like this?



    Note: this is NOT a Traxxas charger.
    Alt-241 on the number pad =

  11. #11
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    250
    Yes, exactly like that, especially the GRR sound and pause. Only does it when it sits for a while. If I use it to multiple batteries in a row, won't do it again. Reason I have posted a sound bite of it yet. Is that sound bad? Chris
    FLM EMBE, P4de "Digger", Slash MT, Rustler/P4de

  12. #12
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,140
    This charger usually does it about 6 to 10 times in a row. Then it's fine until it sits. It did not do this when new. I attribute the sound to the fan going bad, but you should contact Traxxas Support and ask them what they think.
    Alt-241 on the number pad =

  13. #13
    RC Qualifier
    Join Date
    Nov 2011
    Posts
    250
    Thanks, it did it from the first time I plugged it in. I'll call and see what they say. Thanks!
    FLM EMBE, P4de "Digger", Slash MT, Rustler/P4de

  14. #14
    Marshal carraig042's Avatar
    Join Date
    Mar 2004
    Location
    East Tennessee
    Posts
    6,685
    The fan for my Mamba monster does the same thing. The bushings in the fan are dry or dirty. Since it is new, best thing is to contact Traxxas about it.

    -Brett
    4wd Sportmaxx 3.3
    E-Revo - Mamba Monster - Neu 4s

  15. #15
    RC Champion
    Join Date
    Jul 2007
    Location
    Rc Room
    Posts
    1,509
    It's an 80watt 3s max special, but it plugs into the wall!

  16. #16
    RC poster
    Join Date
    Feb 2012
    Posts
    1
    Hi,
    I have just the same charger (but sold under an other name: SkyRC e6680) And i have just the same issue as you have, (only the first time i Charge a battery after plugging the charger in, 10sec, then fan stabilize an works just fine, no problem when the charge is done and then charge an other battery...
    Can jou please tell me if your problem is solved or if this is normal...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •