Page 3 of 3 FirstFirst 123
Results 81 to 96 of 96
  1. #81
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    oh another thing, i'm still unsure on whether or not to run the lipos that aparrently killed my monster, my mate has been running just one at a time in his carnage, and it backflips and goes faster than weve ever seen it go. and it went for 45 mins on 1 half charged and it still never hit lvc. the lipos go like stink, but i darent put them back in my erbe even though i really want to......

  2. #82
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    ............

  3. #83
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    i used these lipos for 6 months as well with no problems, then one day when i'm just messin about doing nothing strenuous and thats when it went up. i just dont wanna sell them and wish that i hadn't, but i dont want to burn up my erbe again neither. all the other lipos i'm getting steered towards are less powerful on the label and they dont seem to have as much punch as these. tips anyone???? i've spoke to loads of people on here that do use label-less lipos and cheap ones with no issues, and some people say their's perform better than the name brands.
    Last edited by kevfrostbite; 12-13-2011 at 05:28 PM.

  4. #84
    RC Champion
    Join Date
    Jun 2009
    Location
    W Monroe, Louisiana
    Posts
    1,991
    It's very likely that it isn't your batteries too.

    Does your charger do internal resistance? Castle recommends to run the lowest Internal Resistance batteries you can find.

    For example, I had two 3s *******'s that never performed well and they were 40c rated. Before placing them in salt water I tested the Internal Resistance and it was 14, 16, 20 for one and 32, 10, 21 on the other. That's pretty high and pretty varied which validates why I never had an kinda punch from those batteries.

    The batteries that i run now are two 2s and all four cells read 1, 1, 1, 1 milliamp.

    If your charger doesn't do that setting then you can check with most electrical volt meters.


    Another sure sign of a weak cells is having different voltages at the end of the run. My old batteries would be 3.57v, 3.31v, 3.40v just for example.

    A good battery will have low internal resistance and matched voltages at the end of the run.



    So Castle didn't tell you what was wrong with your esc? Maybe shoot them an email or something and ask. It won't hurt.
    Last edited by anr2442; 12-13-2011 at 05:59 PM.

  5. #85
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    Quote Originally Posted by anr2442 View Post
    Does your charger do internal resistance? Castle recommends to run the lowest Internal Resistance batteries you can find.

    For example, I had some 3s *******'s that never performed well and they were 40c rated. Before placing them in salt water I tested the Internal Resistance and it was 14, 16, 20 on one and 32, 10, 21 on the other. That's pretty high for one and then pretty varied which validates why I never had an kinda punch from those batteries.

    The batteries that i run now are two 2s and all four cells read 1, 1, 1, 1 milliamp.

    If your charger doesn't do that setting then you can check with most electrical volt meters.


    Another sure sign of a weak cells is having different voltages at the end of the run. My old batteries would be 3.57v, 3.31v, 3.40v just for example.

    A good battery will have low internal resistance and matched voltages at the end of the run.
    the lipos all 6 cells always come back nearly exlactly the same. example, 3.85 3.85 3.84 3.85 3.84 3.84 is typical kind of numbers i get after i used to run them.

  6. #86
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    oh and when the esc did go bang i emailed castle and they said straight away the batteries werent powerful enough. before i had said what lipos i had got, but i think it was just a suggestion. i will email and ask them now in fact.

  7. #87
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    i was told that they were the highest grade cells on the market and not cheap nastiness. you can get them on ebay still, boost revo search should soon find them. they say missive amps etc but i been told not to believe none of that?

  8. #88
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Wales. Uk
    Posts
    741
    Well my motor and esc arrived, a total of 8 weeks. I wasn't as lucky, I didn't get a link in mine. Just a motor that was boxed within a box and a loose esc just rattling around.

    Truth be told a was hoping to get the link as some sort of compensation for the ludicrous wait. But no. Just poorly packaged. My opinion on castle is still a poor one.

    At least my erbe is up and running again.
    Signature removed due to excess awesomeness.

  9. #89
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,603
    Do you not have a C link??
    Would you go flip my truck back over??

  10. #90
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Wales. Uk
    Posts
    741
    No. Thinking I will have to buy one though.
    Signature removed due to excess awesomeness.

  11. #91
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    is your revo still under warranty? i'm thinking it must have been because of that maybe? or maybe it was something to do with the shop that i took mine back to, as they sell the esc's and i think castle must have sorted something out with them? i'm sorry to hear you didnt get the link, and after 8 weeks i think you should have.

  12. #92
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    oh and the traxxas lipos i ordered arrive tomorrow so i will stick them in my erbe and see how they perform. even if they're slower than my old ones i'm gonna run em anyway just so i dont have another fire. i ordered the 5000mah 3s packs to run 6s. castle say they guarantee the traxxas batteries with their motor esc combos so it sounds like a good move to me.

  13. #93
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Wales. Uk
    Posts
    741
    Yeah I was disappointed. I posted it to castle direct, didn't bother with the lhs, would have taken even longer. It was under warranty.

    It cost me 15 postage too so to just get it loose in a box is really poor. A link would have certainly helped with my disappointment in castle. As it is they will stay crap in my mind forever. I hope the kit in the x01 is better!! Traxxas should have partnered with Novak. I hear a lot of folk saying how good their (castles) customer service is, that's not my experience, it's been a totally crappy experience from start to finish.

    Oh well, at least it's running again and really well, the new motor feels much smoother.
    Last edited by revomikey; 12-18-2011 at 11:53 AM.
    Signature removed due to excess awesomeness.

  14. #94
    RC Racer
    Join Date
    Jun 2011
    Location
    stonebroom, uk
    Posts
    104
    hey the x0-1 does look sick, if the revo is doing 97.8mph on youtube, then how fast will this thing go once it been tweaked. thats what i wanna know and can't wait to see it. let me know what you think of it when you get it as i may also be buying one next year. they look pretty mental!

  15. #95
    RC Enthusiast
    Join Date
    Oct 2012
    Location
    Toccoa GA
    Posts
    21
    Ok I bought this E Maxx about 2 weeks ago. First run GREAT awesome fun Second run Fully Charged Traxxas 11.1 Lipos ESC Burns up bout burns the whole Rig down. Call Traxxas and they tell me to send ESC and a the battery it destroyed back to them for Warranty.....Traxxas told me to take the motor to the Hobby shop and have it tested so i did and they said that the motor was fine. so really love the Slash 4x4 that i have and love my brother in-laws Brushless E Revo I bought new Castle ESC and Battery so I could run the Truck......2 mins into the Run GUESS What ANOTHER FIRE.....WTH is going on someone please help

  16. #96
    RC Champion
    Join Date
    Jan 2013
    Location
    Minnesota
    Posts
    1,306
    Quote Originally Posted by blacksheep253 View Post
    Ok I bought this E Maxx about 2 weeks ago. First run GREAT awesome fun Second run Fully Charged Traxxas 11.1 Lipos ESC Burns up bout burns the whole Rig down. Call Traxxas and they tell me to send ESC and a the battery it destroyed back to them for Warranty.....Traxxas told me to take the motor to the Hobby shop and have it tested so i did and they said that the motor was fine. so really love the Slash 4x4 that i have and love my brother in-laws Brushless E Revo I bought new Castle ESC and Battery so I could run the Truck......2 mins into the Run GUESS What ANOTHER FIRE.....WTH is going on someone please help
    Maybe get a cap pack, there might be too much load on the ESC or maybe cheap batterys?
    ERBE
    Savage Flux XL
    Trail finder 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •