Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Oct 2011
    Posts
    8

    Throttle steering problem

    I have a traxxas 2.4 tq link the receiver is green when I turn the controller on but It doesn't turn or doesn't go when I hit the throttle however the steering trim will adjust the wheels I have tried resetting the controller back to default with no success

  2. #2
    RC Champion
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    1,191
    So when you hit the gas or brake your wheels turn? If so your Rx wires are in the wrong channels, reverse the ESC and steering servo wires.

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Jul 2010
    Location
    England
    Posts
    5,788
    That's not what he said, he said he gets no response from the throttle or steering, but the steering trim does adjust the wheels ( which implies the throttle and steering are plugged into the correct slots on the rx ).

    I would say double check them anyway ( refer to the manual ), then rebind the tx to the rx, then recalibrate the tx to the esc ( set forwards, break & reverse ). Beyond that, there are trouble shooting guides in the manual and under the supprt tab at the top of the page.
    Keeping the Mods busy is my specialty...

  4. #4
    RC Enthusiast
    Join Date
    Sep 2008
    Location
    Sweden
    Posts
    28
    hi i have the same problem dont know how to solve it
    Traxxas Rally KB, Traxxas Rustler, TT TS4n

  5. #5
    RC Competitor
    Join Date
    Mar 2012
    Location
    Melbourne, Aust.
    Posts
    69
    Whats the condition of the controller? Has it been dropped or damaged?
    The symptoms would be replicated if aground wire came off the main board, but its very unlikely.

    First thing is first, plug two servos into the receiver and test. if it works then the speed control might have to be recalibrated and the steering servocould have a fault.

  6. #6
    RC Enthusiast
    Join Date
    Sep 2008
    Location
    Sweden
    Posts
    28
    i have never dropped it and nohting like that and if i try to recalibrate esc it donīt works it only flash one time it feels like the tx dosent send any signals but the throttel and stering trim works
    Traxxas Rally KB, Traxxas Rustler, TT TS4n

  7. #7
    RC Champion
    Join Date
    Jan 2003
    Location
    nc
    Posts
    2,060
    I have the same problem on my tqi, steering trim works but not with the wheel. Seems we have a prob here. I sent mine back to traxxas this morn.
    E-revo mmm/2200
    100+mph tc4 neu powered

  8. #8
    RC Champion
    Join Date
    Jan 2012
    Location
    Toronto
    Posts
    2,326
    I had this same problem with another brand, I tried everything but throttle would NOT work, only throttle TRIM would. I sent it back, got a new one and it worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •