Results 1 to 5 of 5
  1. #1
    RC Racer
    Join Date
    Aug 2011
    Location
    AUSTRALIA
    Posts
    200

    Parallel connecting problem?

    Hey when i run my truck im running 2 venom 2C 2000mah with a Parallel connector for longer run time.
    The other day i took my truck out for a run and the thing went flat in 10minutes. (normaly get easy 25min) Stops in its tracks, ESC is very slowly blinking red. So i thought it was low volt detection. when i got home i noticed on my charger the two batteries had different voltage left in them. So i just charged/balanced them again ready for the next run. On my next run the same thing happend, 10 minutes in and trucks stoped in its tracks. Slow red blink on esc. So instead of putting my second packs of batteries in, i disconnected the parallel connector to run the batteries one at a time. One battery was totaly flat where the other battery gave me 20 min run time.
    So does anyone have a clue why one battery is getting drained more than the other? Ive run my truck with the Parallel connector for the last atleast 25 runs. Tho the last 8 runs ive run it with smaller wheels and 50/27 gearing, flipped tranny. The 1st time when this happend i also noticed that my center drive shaft area was hot as! maybe coz the batteries got hot and the heat spread to the rest of the chassis.
    Also the 1st time it happend it also happend with my 2nd set of batteries, one had more voltage left in it than the other when i checked them at home. So i figure its not any of the batteries coz its happening to all of them?
    Im tending to think my wheels and gearing might be running it hot and somehow thats doing something to my batteries. hum...?

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,957
    Check the connections on your adapter...

    Do you have:
    Whatever it is I just said... I could be wrong.

  3. #3
    RC Racer
    Join Date
    Aug 2011
    Location
    AUSTRALIA
    Posts
    200
    dont have, can get, will suss! thanks jimmie

  4. #4
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,957
    Those devices are nearly a requirement to trace down electrical issues...
    Whatever it is I just said... I could be wrong.

  5. #5
    RC Racer
    Join Date
    Aug 2011
    Location
    AUSTRALIA
    Posts
    200
    yeah think its time i get my own and not let a friend use theres for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •