Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Oct 2011
    Posts
    5

    My summit vxl's esc faulty ?

    Hi !
    I 'm a newbie. I bought a this summit 1/16 vxl this summer ant think something is wrong.

    The problem:
    When i switch om the car (by using the ez button on the esc) it led light is bright green an the receiver is red. this should mean that lvc is active. I'm using NiHM and cant switch lvc/lvd off. the esc doesn't seems to respond to my reprogramming attempts.

    when i have the transmitter switched on both esc and receiver led is very dim and flashing (unstable)
    any suggestions ?

    (sorry for my bad English, not my first language)

  2. #2
    RC Racer
    Join Date
    Aug 2011
    Location
    spruce grove alberta
    Posts
    131
    go into your reciever box and unplug your servo from the reciever and see if esc starts functioning properly again

  3. #3
    RC poster
    Join Date
    Oct 2011
    Posts
    5
    I removed the servo and it feels like the esc is working again properly. Is it usual that it fails ? I have not been using it in wet conditions.

  4. #4
    RC Racer
    Join Date
    Aug 2011
    Location
    spruce grove alberta
    Posts
    131
    So the truck goes back and forth properly know? If so then yes the servo is faulty. I have the same truck and my servo also was faulty. In fact im on my 3rd servo. I upgraded to a hs-85mgs by hitec. Its not waterproof so i just dont drive in wet conditions its as simple as that haha. Its a all metal geared and has more torque than the stock one. Its abit slower but not noticable. Its a GREAT servo and i would HIGHLY recommened you buy one. As long as you don't drive in wet conditions. If you must just waterproof it haha.The stock servo is waterproof like the rest of the truck but is just shy of power to turn the big tires and fries itself and shorts out.
    Last edited by summit_slayer_t-maxx; 10-17-2011 at 06:17 PM. Reason: forgot to link to my email

  5. #5
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    There are a lot of servo options out there:
    http://www.servodatabase.com/compare...1677,2119,2130

    I chose the most powerful one, the ******* 390.
    Even though is it the most powerful, it is not the most expensive.
    It is about the same price as a stock servo.

    Also, just a FYI; Any servo can be made waterproof
    Whatever it is I just said... I could be wrong.

  6. #6
    RC poster
    Join Date
    Oct 2011
    Posts
    5
    is it possible to use two servo's ?

  7. #7
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    Yes. But it is much easier to use a single, stronger servo.

    With two, they have to be set up just right; they cannot fight one another. If the fight, they will fry each other. Kind of difficult to adjust a little fight out of a servo when the linkage is not adjustable.
    Whatever it is I just said... I could be wrong.

  8. #8
    RC poster
    Join Date
    Oct 2011
    Posts
    5
    a stupid question, what are the best way to remove the engine ? it's a bit tight to close the reciver box, and get the seal to be in the right place, i want it as water tight as possible. when the winter comes ...

  9. #9
    RC Racer
    Join Date
    Aug 2011
    Location
    spruce grove alberta
    Posts
    131
    The bolt on the blue mount plate is your answer. Theres a silver bolt on the front of the mounting plate. Take it out. Then open your battery box on the reviever side and slide out ur esc a little bit. Then take the motor slide it towads u and pull it off. Then wen u put it back on take of the gear cover (little screw on the front of it) so u can set ur gear mess properly.

  10. #10
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    ^^^
    He is right.
    Whatever it is I just said... I could be wrong.

  11. #11
    RC poster
    Join Date
    Oct 2011
    Posts
    5
    Thanks for the help, now with a new servo it works again, i got a traxxas 2080 again (quick fix) i will take a look at the ******* 390, but i feel i need to waterproof it when i will take the summit out for a winter drive.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •