Results 1 to 13 of 13
  1. #1
    RC Racer
    Join Date
    Jun 2009
    Posts
    244

    Traxxas Esc Glitch?

    I turned on my Summit and it seemed to work fine for about a minute until it stopped and would not go. The lockers, transmission, and steering worked, but the transmitter started flashing slow red and the car would not go. I tried turning it off and back on, but the transmitter started blinking fast red and the light on the receiver turned red. Then nothing happened until about 5 hrs later it did the same thing.
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  2. #2
    RC Qualifier
    Join Date
    Dec 2009
    Location
    Pa
    Posts
    775
    sounds like you have a set of dead batteries in the transmitter or you lost your bind (2.4ghz model).
    Revenge 1/8 buggy

  3. #3
    RC Racer
    Join Date
    Jun 2009
    Posts
    244
    Im going to try to rebind right now
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  4. #4
    RC Qualifier
    Join Date
    Dec 2009
    Location
    Pa
    Posts
    775
    i would also try fresh batteries in the transmitter as well.
    Revenge 1/8 buggy

  5. #5
    RC Racer
    Join Date
    Jun 2009
    Posts
    244
    I did both and it ran fine for one run, but now the transmitter light flickers green and red and sometimes stays solid green.
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  6. #6
    RC Qualifier
    Join Date
    Dec 2009
    Location
    Pa
    Posts
    775
    you might have a bad servo. that tends to do some crazy things to the receiver. like making it twitch or stutter.
    Revenge 1/8 buggy

  7. #7
    RC Champion
    Join Date
    May 2009
    Location
    Southeast PA
    Posts
    1,931
    Quote Originally Posted by OnebadTMAXX3.3 View Post
    you might have a bad servo. that tends to do some crazy things to the receiver. like making it twitch or stutter.
    AGREED! More often than not when you "think" you have an ESC issue it is a bad servo. Try unplugging the servos one at a time. Sometimes a bad steering servo will get HOT and it is easily found this way.
    I make tap adapters and power harnesses.

  8. #8
    RC Racer
    Join Date
    Jun 2009
    Posts
    244
    Ok I will try that but it was the transmitter that was blinking not the receiver.
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  9. #9
    RC Racer
    Join Date
    Jun 2009
    Posts
    244
    Now the transmitter will not turn on
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  10. #10
    RC Racer
    Join Date
    Jun 2009
    Posts
    244
    Now it turns on and i bound the car to the remote again, but my summit is having a massive power drain to the motor
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  11. #11
    RC Qualifier
    Join Date
    Dec 2009
    Location
    Pa
    Posts
    775
    are you running nimh? if so is the batteries hot when you get done using them. They should be warm but not warm as to not be able to handle them. I would insect your batteries. Also did you get the motor hot to where is started to smoke? If you smoked the motor then it is on it's last leg.
    Revenge 1/8 buggy

  12. #12
    RC Racer
    Join Date
    Jun 2009
    Posts
    244
    No the batteries were not warm at all and the motor was not smoking. I am going to try to unplug all of the servos one by one to see if I can flush out the problem
    Slash, Ken Block Fiesta
    Slash 4x4
    Summit

  13. #13
    RC Enthusiast
    Join Date
    May 2009
    Posts
    20
    Very similar thing happening here. It started after a nice long run a few weekends back and it hasn't been out since. It's exactly as described - a huge power drain. Put new batteries in, it'll just die - barely enough juice to turn the wheels. Then out of nowhere, lurch ahead and go full tilt then die. Oddly enough, if I pick it up, it runs again. Set it down, dies. No idea what's up

    Will try the servo suggestion as there was some fidgeting going on. This thing has barely seen any use though so its quite odd indeed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •