Results 1 to 12 of 12

Thread: New 2.5

  1. #1
    RC poster
    Join Date
    May 2011
    Posts
    6

    New 2.5

    Soooooo, i just picked up a used 2.5 from my buddy who was moving (no real details on it)... He gave it to me for free so no money into it (yet!). I have the electric starter all charged up, fresh batteries in the truck and a fully charged glow starter on the new glow plug... The only thing is it doesn't even attempt to turn over. I put the easy starter on the port and press the button and absolutely nothing happens.... Any one have any ideas? Im kinda a newbie if you couldn't tell!

  2. #2
    RC Champion
    Join Date
    Dec 2010
    Location
    Mesa, AZ
    Posts
    2,682
    take the glow plug out, and spray wd40 threw the head and let it soak for a while...probably an hour. the piston is probably stuck. then try to turn it over but without te glowplug in, if it turns over now put the glowplug back in
    Hows that nitro taste on your electric?

  3. #3
    RC poster
    Join Date
    May 2011
    Posts
    6
    ok so before i sprayed wd40 in it i thoguht id give it another shot... when i put the easy start and push the button i get a little click in the easy starter(?) but tnothing for sure happens beyond that

    i will be trying the wd40 here soon...

    thanks for the fast response
    Last edited by facommoguy; 05-30-2011 at 12:06 AM.

  4. #4
    RC Champion
    Join Date
    May 2011
    Posts
    1,255
    Thinking some causes for your problem:
    1- The engine piston is stuck
    2- The EZ- Start (motor, gears, OWB) is broken
    3- Wand broken or battery dead
    4- Clutch stuck (broken)
    Last edited by danyvw; 05-30-2011 at 07:35 AM.
    There are no stupid questions, just stupid people.

  5. #5
    RC Racer
    Join Date
    Feb 2011
    Location
    Fort Hood, TX
    Posts
    156
    Or one of the wires from the port to the ezstart motor is bad.
    Revo 3.3, 2WD Slash, Rustler VXL, and MERV VXL.

  6. #6
    RC Competitor
    Join Date
    May 2011
    Posts
    79
    Normally that click sound when trying to turn it over means the piston could be stuck, be it TDC or just stuck in position.spray some wd40 and try working it, also check all leads to the starting motor etc and all hose lines making sure the adjustment needles wernt screwed down entirely :P
    Revo 3.3 FTW!!

  7. #7
    RC poster
    Join Date
    May 2011
    Posts
    6
    when i press the ez start button the ez starter is trying to turn it over the clicking that i am hearing is in the cylinder next to the motor where the wires connect to

  8. #8
    RC poster
    Join Date
    May 2011
    Posts
    6
    Thinking some causes for your problem:
    1- The engine piston is stuck ( beginning to think that too)
    2- The EZ- Start (motor, gears, OWB) is broken (and this too!!!)
    3- Wand broken or battery dead (going to be trying a new wand today battery is fully charged)
    4- Clutch stuck (broken) (truck still rolls freely?)

  9. #9
    RC poster
    Join Date
    May 2011
    Posts
    6
    GOOD NEWS!!!! So I couldn't find any wd-40 laying around the house so I put a little bit of fuel in there and let it sit for about 15 minutes (a long 15! haha) went back out and was able to spin the umm not sure what its called but in the end got the piston to spin freely and have been out for the last hour and a half driving it! Thanks alot for everyones input

  10. #10
    RC Champion
    Join Date
    Dec 2010
    Location
    Mesa, AZ
    Posts
    2,682
    haha nice.
    Hows that nitro taste on your electric?

  11. #11
    RC poster
    Join Date
    May 2011
    Posts
    6
    now its about getting the 3.3 going!

  12. #12
    RC Champion
    Join Date
    May 2011
    Posts
    1,255
    Good luck man! Enjoy your Revo.
    There are no stupid questions, just stupid people.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •