Results 1 to 4 of 4

Thread: Help :(

  1. #1
    RC Enthusiast
    Join Date
    May 2011
    Posts
    38

    Help :(

    I was out running my KB, the Car just Died. Stopped moving all together . Got the cover off the car and disconnected the battery etc, than reconnected battery. The normal restart procedure etc. When i push the ez set button the receiver blinks green than red than out, no light visible and the LED light on the EC is barely visible red... HELP !!

  2. #2
    RC Qualifier
    Join Date
    Nov 2010
    Posts
    567
    Unplug the servo and see if it turns on like normal. If so call traxxas and let them know. THeyll sort you out

  3. #3
    RC Enthusiast
    Join Date
    May 2011
    Posts
    38
    Being new to the RC world again is tough Lol, thanks for the tip Jono worked great, unplugged the servo and it restored the reverse and forward motion. Called up Traxxas, turned out I had a bad steering servo etc... part number 2080 they sent one out was not a hassle at all was cool, loved that it wasn't a overseas tech but a good ol american walked me through the removal of the servo and gave tips for re installation. Was under warranty so all is good.

  4. #4
    RC poster
    Join Date
    Apr 2011
    Posts
    13
    also make sure u check out some tips of protecting ur servo

    http://traxxas.com/forums/showthread...03#post4817003

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •