Results 1 to 3 of 3
  1. #1
    RC Competitor
    Join Date
    Oct 2010
    Location
    Arizona
    Posts
    63

    Steering issue help NON SERVO RELATED

    I'm not having binding but I can't quite figure it out. I know something is off with my steering setup. I don't remember what I did in the past to the steering as it's held up quite well. I have to modify my front skid plates to fit the steering post because it sits to high. I've tried taking out the washers but the linkage looks like it will hit the drive shaft. Please take a look at my pictures at this link (because I can't seem to post pictures here) Thank you for your help. This is an annoying problem

    http://www.rcuniverse.com/forum/m_10...m.htm#10479617
    Xbox Live: Supa JJ

  2. #2
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Kansas
    Posts
    537
    I can think of two possibilities: The screw that holds the post to the chassis isnít tightened down or thereís something preventing the post from seating all the way. BTW, why did you use a washer in the first place?

  3. #3
    RC Competitor
    Join Date
    Oct 2010
    Location
    Arizona
    Posts
    63
    I'll open up the box to check. The post itself is tight though so I don't know about that one.

    I don't remember what I did to the steering in the past but if I didn't have the washer in there the whole assembly would hit the drive shaft.
    Xbox Live: Supa JJ

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •