Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Apr 2011
    Posts
    8

    Intermittent Summit Trouble

    I have been experiencing some trouble with my Summit lately. Whenever it gets farther that 20 ft away, it doesn't respond too well. It is like it freezes and no commands from the controller seem to work for about 5 seconds. And when it freezes and the wheels are turned, they will stay turned during the "freeze." When it unfreezes, the wheels return back to home position. Any idea what would cause this?

  2. #2
    RC Qualifier
    Join Date
    Apr 2010
    Posts
    489
    is this an older summit or the newer 2.4 ghz? could be radio interference... or bad batteries in your transmitter... or a bad connection from the esc to the receiver...

  3. #3
    RC poster
    Join Date
    Apr 2011
    Posts
    8
    Newer with 2.4 ghz.

  4. #4
    RC Qualifier
    Join Date
    Apr 2010
    Posts
    489
    check all of the wires going to you receiver and servo's and make sure none of them are nicked or cut. and make sure the antenna wire is not cut also...

  5. #5
    RC poster
    Join Date
    Apr 2011
    Posts
    8
    My plastic antenna "case" on my transmitter keeps coming off where it hinges with itself. Could that have anything to do with this problem?

  6. #6
    RC Racer
    Join Date
    Dec 2010
    Location
    Edmonton, AB
    Posts
    233
    That could be your issue, make sure the antenna wire itself is in perfect condition. If it is kinked, cut or broken your range will be very short.
    Waffles!

  7. #7
    RC poster
    Join Date
    Apr 2011
    Posts
    8
    Thanks for the suggestions. I figured out the problem. The wire in my transmitter became unhooked inside. I took it apart and plugged it back in. Works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •