Results 1 to 14 of 14
  1. #1
    RC Qualifier
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    315

    HELP!! receiver problems

    hey everyone, i was using my merv, and it just stopped.... the receiver's light is flashing red, i tried resetting the transmitter, and the esc, and i just tried binding them, and after i turn the transmitter on with the set button on, and it flashes red, i helf the link button on the receiver and turned the esc on, they are supposed to flash red and then turn green... my esc light is green but the receiver light keeps flashing red, along with the receiver... does it have to sit for quite a while? i let them flash for about 5 mins and they never turned green... just kept flashing that red light! HELP! lol ive been having so much bad luck with this thing! first my esc went after i owned it for like 2 or 3 months, my battery grew a bubble and died, and now this! these things are fun and awesome, but im getting some headache! lol
    Last edited by Dadx2mj; 04-01-2011 at 08:36 AM. Reason: Language

  2. #2
    RC Qualifier
    Join Date
    Sep 2009
    Location
    Lancashire - UK
    Posts
    656
    Sorry to say it but if you have a stock esc or servo your going to have problems. some people have a problem where the servo is dodgy and it stops the esc from working properly etc maybe same for reciever. The best thing i did was get a mamba max esc and a hitec hs-85mg servo and a spektrum tx/rx. id call traxxas see what they say
    Last edited by KILO-DELTA; 04-01-2011 at 07:36 AM.

  3. #3
    RC Qualifier
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    315
    how much are those?

  4. #4
    RC Qualifier
    Join Date
    Sep 2009
    Location
    Lancashire - UK
    Posts
    656
    im in uk and i paid approx 300 thats maybe $400 but i did swap a fully upgraded t-maxx for the radio stuff and lipo charger which were from a rc store so didnt kill my wallet.

  5. #5
    RC Qualifier
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    315
    ooh wow lol, im in canada, is there n e thing i can do to fix this one?

  6. #6
    RC Qualifier
    Join Date
    Sep 2009
    Location
    Lancashire - UK
    Posts
    656
    I dont have the traxxas radio system so not sure sorry but have you tried removing the batts from your transmitter and from car for 10mins then put them back in and re try sometimes electrical stuff even tho its turned off still get power from the batts which if there is a problem like yours will not solve it by just turning the stuff off. and if that don't work try taking the reciever out the car and try pairing it on its own with nothing connected but the esc for power.

  7. #7
    RC Qualifier
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    315
    yeah, i dont really wanna deal with wires and stuff, lol, i dont know anything about them, im a newbie. im in to this thing for the better part of 1000 bucks!lol
    Last edited by Dadx2mj; 04-01-2011 at 08:40 AM. Reason: Language

  8. #8
    RC Qualifier
    Join Date
    Sep 2009
    Location
    Lancashire - UK
    Posts
    656
    ? Taking the batteries out is not hard and has nothing really to do with wires altho that is how they are connected. And with rc you have to get to grips with parts (wires/screws/bearings) etc as they can need replacing at regular intervals.

  9. #9
    RC Racer
    Join Date
    Mar 2011
    Location
    Kansas
    Posts
    187
    Hey, have you tried replacing the AA batteries in the transmitter? I think that the light is supposed to flash red when it needs new batteries.

  10. #10
    RC Qualifier
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    315
    yeah i did, the controller still turns on and everything, and when you turn it on, when it works, it makes a little sound like the wheels cutting, and now it dont make no sound when i turn it on... i know how to take the batteries out, i just mean other wires and stuff, i know ill mess something up lol

  11. #11
    RC Qualifier
    Join Date
    Sep 2009
    Location
    Lancashire - UK
    Posts
    656
    Well if you don't try you won't succseed. Maybe you could tell us what the answer is if you did.

  12. #12
    RC Competitor
    Join Date
    Mar 2011
    Location
    Lake Charles, Louisiana
    Posts
    96
    Had the exact same problem last night. Called the Traxxas 800 number, and needless to say. I FRIED the ESC. Mailed it back to them today, and they are shipping new one at no cost!
    Anywhere I go, MERV is with me!

  13. #13
    RC Champion
    Join Date
    Mar 2011
    Location
    Connecticut
    Posts
    2,334
    You must have fried the ESC, then. Sorry to hear about your troubles.

  14. #14
    RC Racer
    Join Date
    Dec 2008
    Location
    Salt Lake City, Utah
    Posts
    215
    Quote Originally Posted by willy911 View Post
    i know how to take the batteries out, i just mean other wires and stuff, i know ill mess something up lol
    Call Traxxas support and they should be able to troubleshoot your problem. Also keep your head up. I bought my first RC 2 years ago. Its an E-Maxx and after 2 days the ESC died. I killed a NIMH battery in the first month, broke multiple parts, and my steering servos died. After the first 1-2 months of awfulness my E-Maxx is running strong for 2 years with only changing parts for hopups.

    Take the time to do some reading and learn how to solder and learn a little bit about the electronics. I surfed these message boards for the most part and learned everything I needed to know. I was a newbie like you, but if you don't try you won't learn. Rarely will you mess something up so bad it can't be fixed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •