Results 1 to 12 of 12
  1. #1
    RC Racer
    Join Date
    Jan 2011
    Location
    Connecticut
    Posts
    135

    Smoked the VXL-3

    I put the lipo 3s-5400 on and the neg wire came off.. The next thing I know smoke everywhere.. I only had the Stampede 4x4 for 2 days and the first time running the 3s lipo 5400.. I imagine there is no warranty for this.. Sucks.. Already order a new VXL-3 System.. Glad I have the 2wd Stampede.. Just took it out of the box to see what that one can do.. No more Lipo batteries for me....

  2. #2
    RC Racer
    Join Date
    Nov 2010
    Posts
    138
    what battery was it a venom? thats a fluke plus the negative coming out wasn't the lipos fault!! lol or the vxls' fault! it just an accident, they happen, don't let it keep you from having fun with lipos they just take a little more care then other types of batteries! And i've been without my Vxl system for 18 days so far Because of the NiHd battery i had, so i guess I wont ever run them either, just Lipos!! lol

  3. #3
    RC Champion
    Join Date
    Jan 2007
    Location
    Michigan
    Posts
    1,678
    Quote Originally Posted by usinkit View Post
    I put the lipo 3s-5400 on and the neg wire came off.. The next thing I know smoke everywhere.. I only had the Stampede 4x4 for 2 days and the first time running the 3s lipo 5400.. I imagine there is no warranty for this.. Sucks.. Already order a new VXL-3 System.. Glad I have the 2wd Stampede.. Just took it out of the box to see what that one can do.. No more Lipo batteries for me....
    So the negative wire came off of what?
    The lipo or the VXL?
    My previous sig conflicted with a forum policy.

  4. #4
    RC Racer
    Join Date
    Jan 2011
    Location
    Connecticut
    Posts
    135
    Yea I shouldnt give up because of one prob.. Just got a little frustrated.. The neg came out of the battery and it was a Venom.. I left a message with Vemon to see if they will help me out with the replacement cost.. If not no worries stuff happens..
    Last edited by Dadx2mj; 01-17-2011 at 05:30 PM. Reason: Language

  5. #5
    RC Turnbuckle Jr. pavmentsurfer's Avatar
    Join Date
    Jul 2009
    Location
    Ontario, Canada
    Posts
    11,145
    Watch the language. sorry to hear about your troubles. But like has been said, sounds like a fluke to me. Im curious though, why would the negative wire coming off smoke the VXL? Unless it was touching something else, it seems strange that this would have caused the ESC to fry.
    Pede, Summit,
    ERBE, Rally,
    Motley Crew, 1SQ

  6. #6
    RC Racer
    Join Date
    Jan 2011
    Location
    Connecticut
    Posts
    135
    Sorry about the language. When I took the body off the wire was touching nothing.. There was just smoke.. I put another battery on after the VXL cooled down and smoke started to pour out again.. I guess it was just a freak thing..

  7. #7
    RC Enthusiast
    Join Date
    Nov 2010
    Location
    Florida
    Posts
    31
    Dude.the same thing happened with me.my wire didn't come off but my motor started to not work and all of a sudden smoke everywhere.I sent mine in to traxxas.they are taking care of it.I'm thinkin that it didn't switch itself to high voltage when changing it to lipo mode.causing it to fry the circuit board.idk.I'm just guessing.or maybe they did a bad job soddering the internals and a wire came off maybe after hitting a bump causing the wire to ground itself.ill tell you wat.ever since this thing came out every thread is how to make it better or how people are disapointed with it.this isn't the quality I expected from TRAXXAS.but there customer service makes up for it.try calling them.ull be very well takin care of.

  8. #8
    RC Enthusiast
    Join Date
    Jan 2011
    Location
    Lorain, Ohio
    Posts
    43
    i was just going to order lipo's on payday but im double thinking that these things cause damage

  9. #9
    RC Enthusiast
    Join Date
    Nov 2010
    Location
    Florida
    Posts
    31
    I was thinking the same thing.but its its just like anything else u upgrade.ull need to upgrade from the ground up to get performance and durability u want.as well as be easy on the throttle..haha and that's hard to do.lol

  10. #10
    RC Enthusiast
    Join Date
    Jan 2011
    Location
    Lorain, Ohio
    Posts
    43
    im just more afraid of them blowing up or something not afraid of them braking a axle or anything

    everyone talks like there bombs lol. so much maintenance balancing them and such or am i wrong can you just plug them into the charger than plug them into the car and they work like a champ?

  11. #11
    RC Racer
    Join Date
    Jan 2011
    Location
    South Florida
    Posts
    154
    Both batts can be bombs haha! I was scared at first with the lipo setup but I honestly think its safer IMO! The cells get balanced out, no heat(my 5000 venom nimh got my esc and motor more hot than my lipo believe it or not) and when its in a hard case like mine it just fits in nicely! Both batteries should be treated with care I just believe the lipo got a bad rep in the begining(and youtube vids) but they have obv stepped up the technology just make sure you read instructions and ask for help from all the wounderful peeps on this forum before charging and running the lipo!
    Good Luck

  12. #12
    RC Racer
    Join Date
    Jan 2011
    Location
    Connecticut
    Posts
    135
    Well Traxxas told me to talk to Venom.. I talked to them and all they would do is replace the battery.. Traxxas said its not there fault.. I just chalked it up as a loss.. I do think Venom should of paid for my VXL though.. It was their poor soldering job that came apart and fried my VXL system..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •