Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Dec 2010
    Posts
    5

    new summit out of box power button stuck on.

    I bought a new 1/16 summit vxl saturday 1-8-11. Got home charged up the battery. When I plugged it in the speed control went into some programing mode. It would blink 1 then 2 then 3 and kept repeating. Took me forever to figure out the power button was stuck on. Played with the button for a little bit. Then I heard it click and it was finally in the off position. I plugged a battery in and when I press the power button it stuck down again LOL. Long store short I tried everything. Pealed the sticker off around the button thinking it was pinching in there. Finally I figured it out.

    After calling traxxas they told me to just send it to them. I had not even got to run it yet so I decided to take it apart and found the problem. After popping the blue cover off you can see the actual button. Its a brown round button in a metal casing on the speed control board. There was glue (or I think the stuff they waterproof the speed control with) packed up all in between the button and its casing. It came off easily with a tiny screwdriver. Without harming anything at all. It works fine now. This took me 2 days of messing around with it to figure it out. Just wanted to post this in case anyone else has the same problem and decided to try to fix it themselves.

  2. #2
    RC Racer
    Join Date
    Dec 2009
    Posts
    149
    Cool you fixed it.

    Be aware you have voided the warranty and the esc is no longer waterproof.

    I totally understand why you did what you did, but I would have tried to exchange it(assuming you bought it at your LHS) before breaking open the speedo...

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    Nice you got it, I would have done the same thing, instead of sending it back and waiting for the esc to come back.

  4. #4
    RC poster
    Join Date
    Dec 2010
    Posts
    5
    Quote Originally Posted by jeff hughes View Post
    Cool you fixed it.

    Be aware you have voided the warranty and the esc is no longer waterproof.

    I totally understand why you did what you did, but I would have tried to exchange it(assuming you bought it at your LHS) before breaking open the speedo...

    The guy from traxxas I spoke on the phone with told me to and I quote. (pick around the switch with a needle and oil it) Nothing I did would have affected the waterproof coating. And to make sure I ran the faucet over it just to make sure. The glue or what ever was in a spot it should not have gotten to. I did not pick at the waterproof coating. The guy at my LHS told me to bring it to him and he would do the procedure for me. He said he had done a few of them lately. My LHS is pretty cool about stuff like this. It is still (warrantied) through them. They are happy because most the time i fix my own problems and don't have to return stuff.
    Last edited by oosel; 01-11-2011 at 07:48 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •