Results 1 to 10 of 10
  1. #1
    RC Racer
    Join Date
    Dec 2009
    Posts
    149

    Another bad speedo...

    My 9 y/o opened his Mini Summit this morning.

    He didn't get across the front yard before the ESC started cutting out.

    This would have been a bummer had this been his first truck, but since he races, he totally gets it. He grabbed our 18 month old MERV and his toolbox, pulled the speedo, installed it in his new Summit, and is ripping as we speak...

    The bad ESC will be sent back to Traxxas on Monday...

  2. #2
    RC Qualifier
    Join Date
    Dec 2009
    Location
    Alberta, Canada
    Posts
    553
    You have a speedometer in your RC's?
    SUMMIT- DeWalt, 4S
    SUMMV- 3S
    MERV- 3S

  3. #3
    RC Racer
    Join Date
    Dec 2010
    Location
    SJ Cali
    Posts
    115
    What is up with these esc's... Everyone seems to be having trouble with them. Traxxas needs to acknowledge there is an issue and take care of it. I had trouble with mine and did some adjustments on my radio that helped, but not %100... I have not talked to anyone that has not had this issue with the summit so something is obviously wrong.

  4. #4
    RC Racer
    Join Date
    Dec 2009
    Posts
    149
    Quote Originally Posted by Traxximus Prime View Post
    You have a speedometer in your RC's?
    speedo is slang for electronic speed control(ESC)

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Dec 2006
    Posts
    4,386
    For what I've seen here in a few ESCs, when they waterproofed the electronics, they put the transparent epoxy all over electronics and over the power transistors too... Then added white thermal paste and glued the heat sink to the power transistors instead of gluing them first and adding the transparent epoxy later to waterproof it... So, basically, it overheats rapidly because there's a thin layer of transparent epoxy between the transistors and the heat sink...
    200, 202, 420, humor 404, 301 to rc10talk, 410.

  6. #6
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,251
    This is pure speculation on my part but I am starting to think Traxxas may have had a bad batch of the VXL-3m ESC, maybe they got a bad batch of a particular component from a supplier or something. This ESC has been in use for a pretty long time without having this issue.My thought is they ran a batch of them when they started production of the mini Summit and that is why the Summit is having this issue while it has not been seen in the other 1/16th scale cars that use the same ESC. Like it has already been stated if you are having issues contact Traxxas they have a great track record and will do what it takes to make it right.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  7. #7
    RC Turnbuckle Jr.
    Join Date
    Nov 2006
    Location
    USA
    Posts
    3,038
    Quote Originally Posted by Dadx2mj View Post
    This is pure speculation on my part but I am starting to think Traxxas may have had a bad batch of the VXL-3m ESC, maybe they got a bad batch of a particular component from a supplier or something. This ESC has been in use for a pretty long time without having this issue.My thought is they ran a batch of them when they started production of the mini Summit and that is why the Summit is having this issue while it has not been seen in the other 1/16th scale cars that use the same ESC. Like it has already been stated if you are having issues contact Traxxas they have a great track record and will do what it takes to make it right.
    I agree, all it takes is one little bad piece in the esc and the whole thing won't work right
    First MiniSlash
    HK6XL Revo 4s 60mph Amsoil dealer

  8. #8
    RC Racer
    Join Date
    Dec 2009
    Posts
    149
    Quote Originally Posted by Dadx2mj View Post
    This is pure speculation on my part but I am starting to think Traxxas may have had a bad batch of the VXL-3m ESC, maybe they got a bad batch of a particular component from a supplier or something. This ESC has been in use for a pretty long time without having this issue.My thought is they ran a batch of them when they started production of the mini Summit and that is why the Summit is having this issue while it has not been seen in the other 1/16th scale cars that use the same ESC. Like it has already been stated if you are having issues contact Traxxas they have a great track record and will do what it takes to make it right.
    I agree, the 18 month old one(same model) is working just fine...

    Dad, what Castle ESC do you run in your MERV?

  9. #9
    RC Racer
    Join Date
    Nov 2010
    Posts
    180
    Man did I ever luck out! I've been following this ESC problem in the forums for over a month now. Finally got my blue Summit VXL yesterday morning. Was already mentally preparing myself for the worst and a phonecall to Traxxas on Monday. But thank goodness mine turned out OK.

    Sorry to hear everyone else's problem. I was totally ready to join the crowd. Just know that once its fixed, this little beast is S-W-E-E-T!

  10. #10
    RC Racer
    Join Date
    Nov 2010
    Posts
    180
    Actually I bought it at Thanksgiving, but my wife made me wait. Thats why I was so nervous, that was at the time all the problems were surfacing.

    I'll keep my fingers crossed it doesn't 'go bad.' So far I've only managed 2 packs of run time, family visiting and all. Only issue I've encountered so far is the slipper clutch seems a bit too loose.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •