Results 1 to 16 of 16
  1. #1
    RC Qualifier
    Join Date
    Apr 2010
    Location
    Somewhere
    Posts
    991

    05 Runs 775 dead

    Ran my summit for about the 5th time. The motor went up in smoke, melted the fans and pretty much everything inside. I was running 18T Pinion was in mud playing. Could that of caused it?

    Last edited by blue_uscg; 08-27-2010 at 04:45 PM.
    No you cant drive it
    my RC is owner operated only

  2. #2
    RC Turnbuckle Jr. noir 522's Avatar
    Join Date
    Sep 2009
    Posts
    3,127
    time for a DeWalt
    MAN, Use Common Sense.
    Outside? THERE IS NO BOX !

  3. #3
    RC Qualifier
    Join Date
    Apr 2010
    Location
    Somewhere
    Posts
    991
    I got one more 775 to burn up first. I put Momba Monster on my E-Revo and going to transplant the 775 into the summit. Then Dewalt or another opition.
    No you cant drive it
    my RC is owner operated only

  4. #4
    RC Qualifier
    Join Date
    Mar 2009
    Posts
    984
    "MAMBA" Monster

    Yes, 18T and mud can do that to the 775. Go Dewalt or get a MMM/2200 for your Summit too.

  5. #5
    RC Champion
    Join Date
    Dec 2009
    Location
    MI
    Posts
    2,502
    Mud has never seemed to effect mine...
    ◄▲▼► SUMMIT ●○●○● 2 RUSTLER VXL's ●○●○● MERV ◄▲▼►

  6. #6
    RC Qualifier
    Join Date
    Mar 2009
    Posts
    984
    I suspect because you're running the stock 14T pinion, no?

  7. #7
    RC Champion
    Join Date
    Aug 2009
    Location
    Spruce Grove, Alberta
    Posts
    1,552
    I tried a 15T pinion in mine when it was still stock. Even with the 15T it got hot, I think the 18T pinion would certainly be to much.
    http://traxxas.com/forums/showthread.php?536733

  8. #8
    RC Qualifier
    Join Date
    Apr 2010
    Location
    Somewhere
    Posts
    991
    I think so but i just built a new set up... going to install it will post pictures tonight..
    No you cant drive it
    my RC is owner operated only

  9. #9
    RC Turnbuckle Jr. noir 522's Avatar
    Join Date
    Sep 2009
    Posts
    3,127
    Quote Originally Posted by blue_uscg
    I think so but i just built a new set up... going to install it will post pictures tonight..
    looking forward to seeing it. stick it in the "Post Up" thread
    MAN, Use Common Sense.
    Outside? THERE IS NO BOX !

  10. #10
    RC Competitor
    Join Date
    Aug 2010
    Posts
    54
    Quote Originally Posted by blue_uscg
    Ran my summit for about the 5th time. The motor went up in smoke, melted the fans and pretty much everything inside. I was running 18T Pinion was in mud playing. Could that of caused it?

    What kinda batteries where u running?
    You ain't bashin if u ain't breakin!!!!

  11. #11
    RC Qualifier
    Join Date
    Apr 2010
    Location
    Somewhere
    Posts
    991
    Venom 5000 mah 2s Lipo
    No you cant drive it
    my RC is owner operated only

  12. #12
    RC Competitor
    Join Date
    Aug 2010
    Posts
    54
    Well that's why u burned it up! Call traxxas, they'll tell u brushed motors like that are not designed for that amount of amps!! I bet it was at least a 20c too! So ur probably pumping 100 amps into a motor the can handle half that. And lipo's put out a continuous volts so it's the same strain when u start as when it cuts off!! Not tapered like nimh! I don't even think traxxas with warranty that motor! I'm not an expert these are just my opinions so anyone feel free to correct me if I'm wrong. But I ran 2 20c 3000mah 16.8v total about 500 times and still ran like new before I upgraded to MMM!! Most Brushed + LiPo = smoking pile of crap
    Last edited by MERVorSUMMIT?; 09-01-2010 at 06:38 AM.
    You ain't bashin if u ain't breakin!!!!

  13. #13
    RC Champion
    Join Date
    Aug 2009
    Location
    Spruce Grove, Alberta
    Posts
    1,552
    Quote Originally Posted by MERVorSUMMIT?
    Well that's why u burned it up! Call traxxas, they'll tell u brushed motors like that are not designed for that amount of amps!! I bet it was at least a 20c too! So ur probably pumping 100 amps into a motor the can handle half that. And lipo's put out a continuous volts so it's the same strain when u start as when it cuts off!! Not tapered like nimh! I don't even think traxxas with warranty that motor! I'm not an expert these are just my opinions so anyone feel free to correct me if I'm wrong. But I ran 2 20c 3000mah 16.8v total about 500 times and still ran like new before I upgraded to MMM!! Most Brushed + LiPo = smoking pile of crap
    lol. you don't "pump" amps. Electric motors draw amps, and they only draw what they require. Amps cannot cause damage to an electric motor. however having batteries that are capable to run a motor to its full potential(and NiMh packs are enough on a brushed motor for this to happen) will allow the user the ability to constantly run a motor to its max potential, and this could be dangerous. Although that is not what has happened in this case. What happened in this case is quite simple. He overgeared it, you cannot run 18t pinion on a 775 and drive it hard. its gonna go boom.
    http://traxxas.com/forums/showthread.php?536733

  14. #14
    RC Champion
    Join Date
    Aug 2009
    Location
    Spruce Grove, Alberta
    Posts
    1,552
    No disrespect intended, but if you are running the 775 with a 18T/68T combo in this situationits gonna burn up. but I bet it was fun
    http://traxxas.com/forums/showthread.php?536733

  15. #15
    RC Competitor
    Join Date
    Aug 2010
    Posts
    54
    Ok u r right I've my $@#t backward. Still learning! I think I bought the wrong lipo's myself! I under powered mine thinking I would do damage if I went to high on the amps! Thanks for the correction! I upreceate u not calling me a retard!! Lol


    Altho I was thinking if u had a battery that didn't let the motor work so hard, in other word an under powered by just a few amps it wouldn't have go so hot, no? Just curious!
    Last edited by MERVorSUMMIT?; 09-01-2010 at 11:59 AM.
    You ain't bashin if u ain't breakin!!!!

  16. #16
    RC Qualifier
    Join Date
    Apr 2010
    Location
    Somewhere
    Posts
    991
    Quote Originally Posted by quadiak
    No disrespect intended, but if you are running the 775 with a 18T/68T combo in this situationits gonna burn up. but I bet it was fun
    Well I will just go with the I forgot it was on there route….
    No you cant drive it
    my RC is owner operated only

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •