Results 1 to 16 of 16
  1. #1
    RC Competitor
    Join Date
    Oct 2008
    Location
    Cheltenham, GL
    Posts
    72

    Ez Start problem

    Im looking at a Jato for a mate of mine that wont start, and normally i can fix most things to do with R/c cars. The problem starts with the Ez Start system, on the cars last outing the glow plug died so it was duly changed and it started first time, later it had a bit of a knock and it broke a lower arm. Since trying to start for the next outing the glow plug light fails to light on the Ez start wand. Ive tried everything to my knowledge, ive changed wiring looms, checked the earth on the motor mount, tried a different glow plug and wand, checked the resistances of the wiring and connection of the pins in the plug! Still no glow plug light! The motor cranks over, fails to start and the light lights up but no glow plug circuit. Any ideas???

    Im stumped!!
    Rustler 2.5
    Jato 3.3
    T Maxx 2.5R
    T Maxx 3.3

  2. #2
    RC Enthusiast
    Join Date
    Feb 2010
    Posts
    32
    I'm a bit of a noob, but here is what I have tried before...undo the glow plug lead and see if it fires up with a glow plug igniter. Is the yellow ground cable still securely attached?

  3. #3
    RC Competitor
    Join Date
    Oct 2008
    Location
    Cheltenham, GL
    Posts
    72
    The ground cable is 100% perfect and the glow plug lights up when powered up. Its just the Ez Start system wont fire the glow plug.
    Rustler 2.5
    Jato 3.3
    T Maxx 2.5R
    T Maxx 3.3

  4. #4
    RC Enthusiast
    Join Date
    Feb 2010
    Posts
    32
    Do you have another starter wand to use...I know buddies who have had terrible luck with the wand (at least for the glow plug part) One buddie has 4 laying around his shop...3 wont work right, and one will.

  5. #5
    RC Competitor
    Join Date
    Oct 2008
    Location
    Cheltenham, GL
    Posts
    72
    Yes ive used the same wand on my own Jato and another wand on the problem jato. Still no luck!
    Rustler 2.5
    Jato 3.3
    T Maxx 2.5R
    T Maxx 3.3

  6. #6
    RC Competitor
    Join Date
    Mar 2010
    Location
    dewitt, mi
    Posts
    86
    ok u didnt say youve tried it but like revo said pull the stupid wire off the glow plug and use an aftermarket igniter bet ya that might solve the problem!!!
    revo slayer conversion that is fun wooohooo!!!

  7. #7
    RC Competitor
    Join Date
    Oct 2008
    Location
    Cheltenham, GL
    Posts
    72
    Yes i have tried it with a glow stick and the glow plugs fine.

    If you read my posts, you can see for yourself!
    Rustler 2.5
    Jato 3.3
    T Maxx 2.5R
    T Maxx 3.3

  8. #8
    RC Racer
    Join Date
    Feb 2010
    Location
    Bakersfield, CA
    Posts
    156
    I think he's saying use a glow plug igniter and the wand to start the car.
    -Eric
    Jato 3.3
    MERV
    Slash 2wd

  9. #9
    RC Enthusiast
    Join Date
    Feb 2010
    Posts
    32
    The only other thing I can think of is your blue wire is fooked up somewhere...maybe torn or burned causing some type of short.

  10. #10
    RC Qualifier
    Join Date
    Jul 2009
    Location
    wichita ks
    Posts
    880
    traxxas ez-start mod
    by: “moe” Shouse moe7404@att,net
    this is an instruction set that modifies the ez-start hand wand to use the battery in your street truck to start your r.c. truck. it will put 12 volts to your starter on your r.c. truck. I can not be sure that it will not harm your ez-start system. however I have been using this mod for 9-10 mo. with no trouble. my r.c. starter has never overheated, and I have cranked it a lot with no trouble. do this mod at your own risk. by using this instruction set you are taking on all risk. now a list of things you need.
    1.radio shack. wire 278-567. 18 gauge speaker wire.
    2.radio shack. cigarette lighter plug. 270-070.
    3.dura trax. battery connector and wire. dtxc2260. radio shack has this connector with out the wire. but its easier to use the dura trax
    4.for reference ez-start hand wand traxxas #5280. about $14
    round up all the parts. first cut a hole in the wand cover. between the belt clip and end of the cover, big enough for the white connector. a soldering iron works good , then trim the edges of the hole. this hole should be 5/8 wide 3/8 tall. now solder the wires on the white connector to the speaker wire. red to red black to black. reinforce the joint. now figure how long the wire is to be. like from the cigarette lighter socket to the tail gate of the street truck. now strip the other end of the speaker wire. tin each wire and insert them into the cigarette plug. now double check the the wire colors to see that the colors are not crossed. now get out your volt meter and check that you get voltage at the wand end, on some sockets you have to have the ign on accs. and that plus volts is on the red wire. now insert the white connector in the to the wand, there is a plus sign just below pins inside the wand that goes to the red wire, and dont force it, you may have to rock it some. now try it on your r.c. car. if it does not work double check your work. also I might have made a mistake, but I have double checked what I written.

  11. #11
    RC poster
    Join Date
    Jan 2012
    Posts
    2
    I have oppnede the ez start with and electronic tech and we found that the diode 1n4001 had exploded wheb good the voltage acros it is 7.6 just like the battery but stil does not work at the glow plug end does anyone have had this diode blown eveything else is good to dissassenmble th ez start have to unsolder the red swithc

  12. #12
    RC Competitor
    Join Date
    Nov 2011
    Location
    florida
    Posts
    69
    I would not trust any ez start,I have one that will spin the ezstart motor but will not ignite the glow plug ,so i have to use that one with an igniter, and yes when i put in in the little hole both lights go green.So i just keep thay one as a backup

  13. #13
    RC poster
    Join Date
    Jun 2012
    Posts
    1

    Another failure!

    Quote Originally Posted by JAMDUDE View Post
    I would not trust any ez start,I have one that will spin the ezstart motor but will not ignite the glow plug ,so i have to use that one with an igniter, and yes when i put in in the little hole both lights go green.So i just keep thay one as a backup
    My brand new Revo 3.3's EZ-Start wand failed to light the glow plug after just 10 starts. I found half of a diode raddling inside the case and realized this was the fault. This is my second Revo 3.3 that failed in some way. My previous one had a TQI radio that died after the firmware update. Serious disappointment!!

  14. #14
    RC poster
    Join Date
    Jan 2013
    Location
    culpeper va
    Posts
    1
    i have a jato 3.3 i had to replace the traxxas EZ start and now that ive done that the motor will not turn over as if it has no power and i have the yellow wire 100% down and when i got to start it the motor light comes on and if i hold it the glow plug light comes on so ive changed the glow plug and it does the same thing. someone please tell me what wrong

  15. #15
    RC poster
    Join Date
    Jan 2013
    Posts
    4
    I am new to this stuff, but I found out the hard way that if you plug the battery in backward the diode will blow and it will not work. I actually heard it pop when I pushed the starter button. I don't remember if the lights come on or not after the diode blew.

    The starter box is kind of a pain to take apart to replace the diode. Once you get the circuit board cover off you need to un-solder the push button from the circuit board to get to the other side where the blown diode is.

  16. #16
    RC Qualifier
    Join Date
    Dec 2010
    Location
    Wake Forest, NC
    Posts
    406
    Sounds like the ez start motor is fouled. Did it get wet or possibly a small rock in it? I have had both happen and it just won't turn over.
    --
    Nitro-J-Rod

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •