Results 1 to 4 of 4
  1. #1
    RC Qualifier
    Join Date
    Sep 2005
    Location
    Va
    Posts
    388

    ESC programming????

    I am trying to program the ESC in my PE. I have a Spektrum ds3(not 3.0). I reset the remote to factory settings. When I turn on the esc it is green, I hold it until it turns red then let off and when i get 1 red blink I hold the throttle full open.......it does nothing. What am I doing wrong?
    Run What Ya Brung and Pray You Brung Enough!

  2. #2
    RC Qualifier
    Join Date
    Sep 2005
    Location
    Va
    Posts
    388
    I do not understand this forum......I have a Traxxas product that I am asking a question about and I am breaking a rule??? Is it because I am asking with a Non-traxxas product invovled? If thats the case they should have included a radio with it. I am sorry but the past couple of days I have had 4 post deleted. I got a warning for a word that was not offensive or bad language. I figured the problem out on my own.....just thought maybe I could get some help. Sorry Traxxas.
    Run What Ya Brung and Pray You Brung Enough!

  3. #3
    RC Turnbuckle Jr. asheck's Avatar
    Join Date
    Nov 2007
    Location
    Kansas City
    Posts
    7,361
    Have you tried reversing your throttle channel? Are you holding the on button till it turns red, or turning it on, then pressing again till it turns red and blinks?
    _
    _
    _ 3 lines are all that's allowed in a sig.

  4. #4
    RC Qualifier
    Join Date
    Sep 2005
    Location
    Va
    Posts
    388
    I got it fixed. Thanks for the input.
    Run What Ya Brung and Pray You Brung Enough!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •