Results 1 to 6 of 6
  1. #1
    RC Champion
    Join Date
    Mar 2008
    Location
    st. helens, Or
    Posts
    1,373

    radio wont link to new receiver

    anybody else having this problem....i held the set button on the radio while powering up then held the link button while turning on the esc...the radio blinks red and the receiver blinks green...but they never find each other...and i can't find any type of troubleshooting for this...$45 receiver at the lhs...and i almost just bought a new spektrum receiver
    @ 80% for years?

  2. #2
    RC Qualifier
    Join Date
    Jan 2010
    Posts
    300
    Dang phone....dbl posted
    Last edited by yeti as3; 02-06-2010 at 06:37 AM.

  3. #3
    RC Qualifier
    Join Date
    Jan 2010
    Posts
    300
    I just had the same prob! If you have the newest Traxxas Link 2.4 radio you are out of luck until mid-late Feb,they are just getting the new receivers to the consumer.
    Yout LHS prob gave you the older 4ch 2.4 receiver #2217 ....what you need is the new one. #2218. I ended up buying the DX3s after I returned #2217. My LHS (good one too) was never notified by Traxxas that they were not compatible.

  4. #4
    RC Qualifier
    Join Date
    Sep 2009
    Location
    CT
    Posts
    291
    Does the receiver box have the word LINK on it? If no then it wont work with the new LINK radio. The older 2.4 ghz radios do work with the new link receivers. I traded up my AM radio/receiver VIA traxxas power up program, and they sent me a Non Link radio and a Link receiver that work great in my 4x2.

    Here is a thread that has further link info:
    http://monster.traxxas.com/showthrea...link+explained
    You're not too old if you're still having fun!

  5. #5
    RC Champion
    Join Date
    Mar 2008
    Location
    st. helens, Or
    Posts
    1,373
    "then held the link button while turning on the esc"....it has the link button
    @ 80% for years?

  6. #6
    RC Enthusiast
    Join Date
    Aug 2009
    Posts
    34
    Yeti is correct. I had the same exact problem. i ordered the link receiver 2217 from my lhs but it didnt work until i swapped out from my back up slash receiver 2218. The 2218 is the correct reciver for the slash 4x4 transmitter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •