Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Jan 2010
    Location
    Hillsboro, OR
    Posts
    13

    Loss of braking after 2.4 GHz upgrade

    I recently purchased the Stampede VXL, then a couple of weeks later upgraded to 2.4 GHz Tx/Rx using the Traxxas 2.4 GHz 4-Channel setup. Before the change, the brakes worked incredibly well (easily lockup and spin the truck 180 degrees on wet pavement). Since the upgrade, we can't get the brakes to even come close to locking up, not even on wet grass! I've performed a Tx/ESC reprogramming per the instructions, no difference. I've tried doing some adjusting with the throttle trim, still no difference. From full speed, it now takes the truck twice as long to stop (bad deal when a curb or other solid object is coming up). The trucks gearing is stock and we're running a 7.4 NiMh battery, no other mods to the truck. Has anyone run into this issue when upgrading using the Traxxas setup? Any recommendations? I'm less then satisfied with this upgrade , and since I traded in the original Tx/Rx to get this one (using the Traxxas Upgrade program offered thru a local hobby shop) I no longer have them to switch back.

  2. #2
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,917
    Silly question: did you have the throttle trim centered when programming?

  3. #3
    RC Qualifier
    Join Date
    Dec 2001
    Location
    Dallas, TX
    Posts
    669
    Make sure your Throttle Neutral Adjustment is set to 50/50 and not 70/30.

  4. #4
    RC poster
    Join Date
    Jan 2010
    Posts
    3
    I would try to reprogram it again. I also upgraded and lost brakes. i reprogramed the esc by holding the power tell the esc turns red, release, wait tell it blinks red once, hold throttle, blinks twice, hold reverse, blinks green, done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •