Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Jan 2010
    Location
    Bakersfield
    Posts
    6

    another binding problem

    Just purchased a 4 channel 2.4 radio with traxxas link. The Reciever that came with was pre bound and worked fine. Got an extra 4 channel reciever for my losi and followed the bind procedures and nothing. The reciever just keeps flashing green. Never turns solid. Been messin with it for a few hours. My head is gettin balder by the minute. Theres probibally somethin on this allready but havent been able to find a thread that has solved my problem.

  2. #2
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Montgomery AL
    Posts
    950
    Uhm, wrong receiver? The correct rcvr is a 2218 which is 5 channel.
    US Navy retired, now - FAA air traffic controller

  3. #3
    RC poster
    Join Date
    Jan 2010
    Location
    Bakersfield
    Posts
    6
    Oh man. I got the 2217 cus thats all that i could find. It was my understanding that if they were both the black models it should work

  4. #4
    RC Qualifier
    Join Date
    Jan 2010
    Location
    Montgomery AL
    Posts
    950
    For the new LINK system, the rcvr has to be the 2218 ....they are out there but the price is running a bit high due to low inventory and many dealers are back ordered.

    I paid a bit more than I should have for 2 more rcvrs so that I could use them in my 3 vehicles. Wouldn't you know it ... then my new transmitter went belly up and as we speak it is on it's way back to TRAXXAS. So I am back to my old radios until I get it back. Brandy new 2218 rcvrs just sitting and waiting!
    US Navy retired, now - FAA air traffic controller

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •