Results 1 to 22 of 22
  1. #1
    RC Racer
    Join Date
    Apr 2009
    Posts
    143

    I think I found my problem..Pictures

    Alright after thinking I found the problem of why im only able to get 17.9mph I tried it again today and its still the same 17.9mph time after time. Dont know why I thought this but I took the cover off of the driveshaft and this is what I found. Does this have anything to do with my slow speed?[IMG][/IMG]

  2. #2
    RC Qualifier
    Join Date
    Oct 2008
    Location
    Minnesota
    Posts
    541
    lol heck yah.
    T8 sensored/Xerun-150a/custom chassis/fit body

  3. #3
    RC Racer
    Join Date
    Nov 2008
    Location
    Nor-Cal
    Posts
    205
    Wow there's the problem allright. Thats crazy.....
    Slower Traffic Keep Right.........

  4. #4
    RC Qualifier
    Join Date
    Feb 2009
    Location
    South-Eastern, Pennsylvanian
    Posts
    470
    Well there's your problem. lol
    [QUOTE=Corrijo]Welcome to the crazed family of summit owners.[/QUOTE]

  5. #5
    RC Racer
    Join Date
    Apr 2009
    Posts
    143
    The only reason I found this is because when I was done running it when I picked it up I about burnt my hand on the cover down there. At first I thought it might be the batteries making it hot but im glad I took that off. I would like to know how long thats been like that.

  6. #6
    RC Qualifier
    Join Date
    Nov 2008
    Posts
    305
    probably happened after one of your kid pulls, probably the carpet pull

  7. #7
    RC Racer
    Join Date
    Apr 2009
    Posts
    143
    Does anyone make an aftermarket metal Center driveshaft for the summit?

  8. #8
    RC Qualifier
    Join Date
    Apr 2009
    Location
    Melbourne, FL
    Posts
    734
    Quote Originally Posted by Mustang8402
    Does anyone make an aftermarket metal Center driveshaft for the summit?
    http://204.186.93.64/Summit-CenterDogBone.htm

  9. #9
    RC Qualifier
    Join Date
    May 2008
    Location
    Oxford, MA
    Posts
    441
    All that pretzel is missing is some salt!
    HPI SavageFlux & Baja-HobbyZone Champ-Eflight MSR

  10. #10
    RC Enthusiast
    Join Date
    Sep 2008
    Posts
    37
    Quote Originally Posted by Mustang8402
    Alright after thinking I found the problem of why im only able to get 17.9mph I tried it again today and its still the same 17.9mph time after time. Dont know why I thought this but I took the cover off of the driveshaft and this is what I found. Does this have anything to do with my slow speed?[IMG][/IMG]

    Is that a real question? lol, that may affect your speed just a little
    If you get stuck, lock the diffs and crawl out

  11. #11
    RC Turnbuckle Jr. icepick832's Avatar
    Join Date
    Apr 2007
    Location
    Indian Trail N.C.
    Posts
    3,294
    Wow!!!! Thats a cool carnage shot if I ever saw one....lol. I would say, YES , thats your issue.

  12. #12
    RC Racer
    Join Date
    Jun 2008
    Location
    Brisbane Australia
    Posts
    211
    Did it not make a noise ????

  13. #13
    RC Racer
    Join Date
    Apr 2009
    Posts
    143
    didnt make a sound and like I said other than the speed issue it ran and drove great!

  14. #14
    RC Qualifier
    Join Date
    Sep 2008
    Location
    Bonnie Scotland
    Posts
    643
    Another issue could be binding in bearings in areas of the truck. Or just general roughness. just an observation but with the rest of the rust on the truck it might be time to swap out some bearings if they are stiff of gritty
    I was born to break the mould

  15. #15
    RC Qualifier
    Join Date
    Jan 2009
    Location
    Wisconsin
    Posts
    633
    wow know that horsepower these summit's have that much torque

  16. #16
    RC Racer
    Join Date
    Mar 2008
    Location
    Moe's Tavern, buying Barney some Duff.
    Posts
    115
    Looks fine to me.
    Where'd that tree come from?!?!?!?!?!

  17. #17
    RC Champion
    Join Date
    Oct 2007
    Location
    In the AC system of my LHS...
    Posts
    1,226
    Geez...I'm surprised that the driveshaft end didn't go out first. The kit chet jamio suggested should do the job well.


  18. #18

  19. #19
    RC Qualifier
    Join Date
    Jul 2009
    Location
    Ohio
    Posts
    411
    40 dollars do you know how many sets of stock shafts you can get for that. really strange how it twisted ..you'd think it would just snap off the yoke.
    E REVO 3.3 t maxx wheels/tires 80a 2330kiv ezrun

  20. #20
    RC Champion
    Join Date
    Jan 2007
    Location
    regina sask, canada
    Posts
    2,344
    if your not breaking anything get more air

  21. #21
    RC Qualifier
    Join Date
    Apr 2003
    Location
    Beyond the Sun..
    Posts
    597
    EEks! That MIGHT slow your speed some.
    END_OF_LINE

  22. #22
    RC Qualifier
    Join Date
    Sep 2008
    Location
    Pittsburgh
    Posts
    852
    just think........

    if you put those metal shafts in.... what is going to break in its place...

    no thanks...

    keep some factory spares around.. for often it breaks.....i would not worry about it...
    Three Summits

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •