Page 2 of 2 FirstFirst 12
Results 41 to 53 of 53
  1. #41
    RC Qualifier
    Join Date
    Mar 2009
    Posts
    256
    Bummer, SaintedNine. There seems to be some of the faulty axles still out there. I've not had any real trouble with mine. I think mine was a early Summit, IDK but it does have the tires without the raised lettering.

    At any rate, to the point of the OP, I've mostly been charging batteries. I did set up a battery charging box in the basement and ordered some parts (body, wheels, tires, new battery connectors) but haven't had time to mess with them much.

  2. #42
    RC poster
    Join Date
    Mar 2009
    Location
    Edmonds, WA
    Posts
    15
    Quote Originally Posted by Dingman
    Bummer, SaintedNine. There seems to be some of the faulty axles still out there. I've not had any real trouble with mine. I think mine was a early Summit, IDK but it does have the tires without the raised lettering.

    At any rate, to the point of the OP, I've mostly been charging batteries. I did set up a battery charging box in the basement and ordered some parts (body, wheels, tires, new battery connectors) but haven't had time to mess with them much.
    I think I'll be fine once I get the replacements in. I think I was just one of the unlucky ones who got the bad parts with my summit. My tires don't have the raised letters as well, so I guess I got an early one. I've only had it for a couple weeks, but I ordered it online.
    The Dude Abides...

  3. #43
    RC Qualifier
    Join Date
    Nov 2008
    Posts
    305
    my tires do not have any lettering on them nor does my co-worker and my front 5678 snapped and his has not so i do not know if that is the way to tell it looks like pot luck on getting a good or bad set.
    Also once again today we went out and did some hillside bashing on a summit made track and nothing is funner than racing/bashing with a buddy.

  4. #44
    RC Enthusiast
    Join Date
    Feb 2009
    Posts
    45
    decided to just a pickup truck at work,and did so and then broke the front bumper mount

  5. #45
    RC Qualifier
    Join Date
    Mar 2009
    Posts
    256
    New parts installed. Although calling shock spring covers an "install" is "stretching" it.


  6. #46
    RC Competitor
    Join Date
    Apr 2009
    Posts
    94
    I personally am waiting for my replacement parts to come in. Broke an output shaft in the rear diff. On a lighter note, I set up 6 more LED's on the summit's body. Four white in the top light rack and two red on the upper part of the rear. It's pretty sweet, Ill post some pictures.

  7. #47
    RC Qualifier
    Join Date
    Nov 2008
    Posts
    305
    installed lvc into rx box and made my bec side harness so i can run lipo or nimh.

  8. #48
    RC poster
    Join Date
    Apr 2009
    Location
    Oregon
    Posts
    15
    Hey Koko,
    Where did you position the Smart-Stop in the receiver box?
    I'm trying to get it to fit, but doesn't.
    TIA

  9. #49
    RC Champion
    Join Date
    May 2008
    Location
    SAINT CHARLES, MO
    Posts
    2,314
    did you grind off the nub on the inside of the reciever box?
    EMAXX-x2,SUMMIT
    RUSTLER VXL
    FERRITE RINGS PM ME!

  10. #50
    RC Qualifier
    Join Date
    Nov 2008
    Posts
    305
    i just layed it in there and i had no problem it fit fine just try to position it forward and above the tlock.

  11. #51
    RC Qualifier
    Join Date
    Nov 2008
    Location
    Castaic, CA
    Posts
    480
    I just had to replace my shifting servo this week it went out on me after about 2 months. I called Traxxas customer support and told them the issue and they offered to send me a new one as a courtesy. So that was back on Saturday and I got it in the mail yesterday and everything is back up and running 100%.

    Traxxas just sealed the deal for a life long customer from that one call unlike most other companies I have dealt with in the past.
    "Lead, Follow, or get out of the way"

  12. #52
    RC Qualifier
    Join Date
    Mar 2009
    Location
    Roseville, Ca.
    Posts
    385
    Quote Originally Posted by kscherer3153
    I just had to replace my shifting servo this week it went out on me after about 2 months. I called Traxxas customer support and told them the issue and they offered to send me a new one as a courtesy. So that was back on Saturday and I got it in the mail yesterday and everything is back up and running 100%.

    Traxxas just sealed the deal for a life long customer from that one call unlike most other companies I have dealt with in the past.

    Yup, Traxxas has me too. Always willing to back their product. The 4 yr old and I installed shiney stuff and went bashing, crawling, and then the ensuing cleaning on my summit. He brought his little rubicon and would carry it up the side of the rocks i was climbing, and then launch it off the pile with a short "air" and then big crashes to the bottom. he had a blast.
    Last edited by Corrijo; 04-25-2009 at 08:08 PM.
    Corrijo
    When the muds flyin, don't call me.

  13. #53
    RC Qualifier
    Join Date
    Oct 2008
    Location
    Minnesota
    Posts
    541
    drove it in the rain

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •