Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Mar 2009
    Posts
    5

    New brushless e-Revo owner questions

    Hi,

    About 6 months ago I purchased an e-revo brushless used on ebay, before Traxxas released the ERBE (sniff sniff).

    Unfortunatly the economy in Iceland collapsed and my car was stuck in the US (at a friends house) for half a year. Finally I got the car last week and I have been taking it out for a spin.

    Iīve been searching the forums but I cannot find a solution to my problem, but this forum is just filled with good e-revo info.

    My problem is when I power on the ESC the motor revs up to probably max for about 1-3 seconds then it stops and works fine. This is a bit annoying cause I have to have the car with the wheels in the air when I power it on and holding a brushless vehicle with one hand while using the other to power it on going straight to max rev is... well, not good

    Other question I have is about gearing. I have a Novak 6.5 (doesnīt say on motor though), ESC with purple heatsink and current gearing is 68/12. As far as I can tell I should be around 68/14 or 68/15. But just wanted to double check with those who have more knowledge about the subject, should I go for 68/15 or some other gearing?

    Information:
    Motor Novak 6.5
    ESC with purple heatsink
    Novak Capacitor
    Reciever Spektrum DSX 2.0 (SR3000)
    Batteries: 2x 4600 Mah A123's


    Thanks in advance,
    Caaine

  2. #2
    RC poster
    Join Date
    Mar 2009
    Posts
    5
    I also wanted to ask if it would be possible to use a Neu 1515/1Y motor with the Novak HV ESC if I donīt plan on using more than 4S anyways?

    Reason I ask is I could maybe get a Neu motor for a reasonable price and just wondering if it would be a possible upgrade.

  3. #3
    RC Turnbuckle Jr.
    Join Date
    May 2007
    Location
    Kerrville Tx
    Posts
    4,997
    novak will only run novak

  4. #4
    RC Qualifier
    Join Date
    May 2007
    Posts
    719
    I had a similar issue with my DX3R when I realized the safety range the Spektrum picked up was totally off. Make sure your throttle subtrim, etc. are zeroed and then bind it again, it might fix the problem.

  5. #5
    RC poster
    Join Date
    Mar 2009
    Posts
    5
    Thanks for the answers, will try that!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •